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Computer-Aided Design (CAD) with FreeCAD 

Grade Level: High School (Grades 9–12) 

Duration: 16 Weeks (One Semester) 

Class Frequency: 2–3 sessions per week 

Software: FreeCAD (Latest Version) 

Prerequisites: Basic computer literacy 

 

Course Objectives 

By the end of this course, students will: 

 Understand the fundamentals of CAD and FreeCAD software. 

 Develop 2D sketches and transform them into 3D models. 

 Learn parametric modeling concepts for design efficiency. 

 Apply CAD skills to real-world engineering and design problems. 

 Create technical drawings and export models for 3D printing. 

 

Course Outline 

Module 1: Introduction to CAD & FreeCAD (Weeks 1–2) 

Lesson 1: Introduction to CAD 

 What is Computer-Aided Design? 

 Real-world applications (Engineering, Architecture, Product Design) 

 Overview of FreeCAD 

Lesson 2: FreeCAD Interface & Navigation 

 Installing and setting up FreeCAD 

 Understanding workbenches (Sketcher, Part, Part Design) 

 Navigating 3D space (Pan, Zoom, Rotate) 

Activity: Explore FreeCAD interface and create basic shapes (cube, cylinder, sphere). Print 

Name Plate (introductory lesson) 
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Module 2: 2D Sketching & Constraints (Weeks 3–4) 

Lesson 3: Sketcher Workbench 

 Creating basic 2D sketches 

 Understanding constraints (geometric & dimensional) 

Lesson 4: Parametric Design Basics 

 Using constraints to control dimensions 

 Editing sketches with parameters 

Activity: Design a simple 2D sketch of a keychain with dimensions. 

 

Module 3: 3D Modeling & Part Design (Weeks 5–6) 

Lesson 5: Extrusion & Revolution 

 Extrude a 2D sketch into 3D 

 Revolve a profile to create round objects 

Lesson 6: Adding Features (Fillets, Chamfers, Holes) 

 Understanding feature-based modeling 

 Applying fillets, chamfers, and holes 

Activity: Model a simple mechanical part (e.g., a bracket or simple gear). 

 

Module 4: Assembly & Advanced Modeling (Weeks 7–9) 

Lesson 7: Combining Parts (Boolean Operations) 

 Union, Difference, Intersection in the Part Workbench 

Lesson 8: Multi-Part Assemblies 

 Using the Assembly Workbench 

 Aligning and constraining parts 

Activity: Create a simple assembly (e.g., a door hinge or a small box with a lid). 
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Module 5: Technical Drawings & Documentation (Weeks 10–11) 

Lesson 9: Drafting & Technical Drawings 

 Using the TechDraw Workbench 

 Adding dimensions and annotations 

Lesson 10: Exporting & File Formats 

 Exporting to STL for 3D printing 

 Saving files in different formats (STEP, IGES, DXF) 

Activity: Generate a technical drawing for a completed part. 

Module 6: Real-World Applications & Capstone Project (Weeks 12–16) 

Lesson 11: 3D Printing Basics 

 Preparing a CAD model for 3D printing 

 Using slicer software 

Lesson 12: Reverse Engineering & Design Challenge 

 Students pick an everyday object to model and improve its design 

Final Project: 

 Students design, document, and present a functional CAD model (e.g., phone stand, 

small tool, mechanical part). 

 Optional: 3D print selected projects. 

Assessment & Grading 

 Class Participation & Exercises (20%) 

 Mini Projects & Assignments (30%) 

 Technical Drawing Submission (20%) 

 Final Project (Design + Presentation) (30%) 

Materials Needed 

 Computers with FreeCAD installed 

 3D printer (optional but recommended) 

 Digital calipers (for reverse engineering project) 

 Notebook for sketching & notes  
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Lesson 1: Introduction to CAD 

Duration: 1–2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will understand the purpose and applications of Computer-

Aided Design (CAD) and how FreeCAD fits into the broader CAD landscape. 

 

1. What is CAD? (15–20 minutes) 

 Definition: 
o Computer-Aided Design (CAD) refers to the use of software to create precise 

drawings and 3D models for engineering, architecture, and design. 

 Why use CAD instead of manual drafting? 
o Precision and accuracy 

o Faster iteration and modification 

o 3D visualization before manufacturing 

o Integration with 3D printing and CNC machines 

 Historical Perspective: 
o From hand-drawn blueprints to digital modeling 

o Evolution of CAD software (AutoCAD, SolidWorks, Fusion 360, FreeCAD) 

Discussion Question: 

 Can you think of objects around you that were designed using CAD? (E.g., smartphones, 

furniture, cars) 

 

2. Real-World Applications of CAD (15–20 minutes) 

 Industries using CAD: 
o Engineering: Mechanical parts, machine components, structural analysis 

o Architecture: Floor plans, 3D building models, interior design 

o Product Design: Consumer electronics, furniture, tools 

o Animation & Game Design: Character modeling, environment creation 

o Medical Field: Prosthetics, dental implants 

Activity: 

 Show real-world CAD models (via images or videos) of cars, buildings, and everyday 

objects. 

 Ask students to brainstorm other applications of CAD. 
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3. Introduction to FreeCAD (15–20 minutes) 

 What is FreeCAD? 
o Open-source, parametric 3D modeling software 

o Free to use, suitable for engineering and product design 

o Modular with different workbenches (Sketcher, Part, Assembly, TechDraw) 

 Comparison with other CAD Software: 
o FreeCAD vs. AutoCAD, SolidWorks, Fusion 360 

o Strengths of FreeCAD: Open-source, parametric modeling, 3D printing support 

Activity: 

 Show FreeCAD’s interface and sample projects (preloaded models). 

 Have students install FreeCAD on their computers if not already done. 

 

4. Hands-on Exploration (Optional – 20 minutes) 

 Guided Activity: 
o Open FreeCAD and create a new project. 

o Navigate the workspace (zoom, rotate, pan). 

o Insert a simple 3D shape (cube or cylinder). 

Homework Assignment: 

 Research one industry that uses CAD and write a short paragraph on how it benefits from 

CAD technology. 

 

This lesson provides an engaging and interactive introduction to CAD while helping students 

understand its importance. 
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Lesson 2: FreeCAD Interface & Navigation 

Duration: 1–2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will be able to navigate the FreeCAD interface, understand its 

key components, and manipulate objects in 3D space. 

 

1. Overview of FreeCAD Interface (15–20 minutes) 

a. Starting FreeCAD 

 Open FreeCAD and create a new document. 

 Introduction to the Start Page and creating a new project. 

b. Key Interface Components 

1. Menu Bar & Toolbars – Contains essential commands (File, Edit, View, etc.). 

2. Workbenches – Specialized toolsets for different modeling tasks:  

o Sketcher – For 2D sketches 

o Part – Basic 3D shape creation 

o Part Design – Parametric modeling 

o Assembly – Combining multiple parts 

o TechDraw – Creating 2D technical drawings 

3. Combo View Panel – Displays the Model Tree and Task Panel. 

4. 3D Viewport – The main workspace where models are displayed. 

5. Navigation Cube – Helps orient the view (Top, Front, Side). 

6. Status Bar – Displays messages, coordinates, and progress. 

Activity: 

 Walk students through opening FreeCAD and identifying interface components. 

 Ask students to explore different workbenches and note differences. 

 

2. Navigating the 3D Workspace (15–20 minutes) 

a. Basic Navigation Controls 

 Orbit (Rotate View): Middle Mouse Button + Drag 

 Pan: Shift + Middle Mouse Button + Drag 

 Zoom: Scroll Wheel 
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Alternative Navigation Methods: 

 Use Navigation Cube to change views quickly. 

 Use View Toolbar to switch between orthographic and perspective views. 

Activity: 

 Have students practice rotating, panning, and zooming in FreeCAD. 

 Challenge: Ask them to navigate to a specific angle and describe their view. 

 

3. Creating and Manipulating Basic Shapes (20–30 minutes) 

a. Creating Primitives in Part Workbench 

 Switch to the Part Workbench. 

 Use the toolbar to create:  

o Cube 

o Sphere 

o Cylinder 

o Cone 

b. Modifying Object Properties 

 Select an object and adjust its size in the Property Panel. 

 Move objects using the Placement Tool. 

Activity: 

 Have students create and arrange multiple primitives in a scene. 

 Challenge: Resize a cube to match specified dimensions (e.g., 50mm x 30mm x 20mm). 

 

4. Saving and Managing Projects (10–15 minutes) 

 Saving a Project: File → Save As 

 Opening an Existing Project: File → Open 

 Exporting for 3D Printing: File → Export → Choose STL format 

Activity: 

 Students save their current project and reopen it to ensure they understand file 

management. 
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Homework Assignment: 

1. Written Task: List and describe at least three different FreeCAD workbenches. 

2. Practical Task: Create a simple 3D scene with at least three different primitives and save 

it. 

 

This lesson gives students a strong foundation in navigating FreeCAD, preparing them for 

sketching and modeling. 
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Lesson 3: Sketcher Workbench 

Duration: 2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will understand how to use the Sketcher Workbench in 

FreeCAD to create 2D sketches with constraints, which are the foundation for 3D modeling. 

 

1. Introduction to the Sketcher Workbench (15–20 minutes) 

a. What is the Sketcher Workbench? 

 The Sketcher Workbench is used to create 2D sketches, which serve as the base for 3D 

models. 

 It allows for precise control of shape dimensions using constraints. 

 Sketches can be extruded, revolved, or cut to form 3D objects. 

b. Entering the Sketcher Workbench 

1. Open FreeCAD and create a new document. 

2. Switch to the Sketcher Workbench. 

3. Click "Create New Sketch" and choose a reference plane (XY, XZ, or YZ). 

 

2. Creating Basic Sketches (20–30 minutes) 

a. Sketching Tools Overview 

Students will learn how to use the following tools: 

 Line Tool – Draw straight lines. 

 Polyline Tool – Create connected lines. 

 Rectangle Tool – Draw rectangular shapes. 

 Circle & Arc Tools – Create circular and curved shapes. 

 Spline Tool – Draw complex curves. 

b. Hands-on Activity: Drawing a Simple Sketch 

1. Create a new sketch on the XY plane. 

2. Draw a rectangle using the Rectangle Tool. 

3. Draw a circle inside the rectangle. 

4. Experiment with lines and arcs to modify the design. 
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3. Applying Constraints (20–30 minutes) 

a. What Are Constraints? 

 Constraints are rules that define relationships between sketch elements to ensure 

precision. 

 Two types of constraints:  

1. Geometric Constraints (e.g., perpendicular, parallel, tangent) 

2. Dimensional Constraints (e.g., length, angle, radius) 

b. Applying Geometric Constraints 

 Select two lines → Click Parallel Constraint. 

 Select a corner of a rectangle → Click Perpendicular Constraint. 

 Select a circle and a line → Click Tangent Constraint. 

c. Applying Dimensional Constraints 

 Select a line → Click Length Constraint (set a specific length). 

 Select an angle between two lines → Click Angle Constraint. 

 Select a circle → Click Radius Constraint to define its size. 

Activity: 

 Have students fully constrain a rectangle with a circle inside it. 

 Challenge: Modify their sketch so that resizing one dimension adjusts others 

proportionally. 

 

4. Editing and Fixing Sketches (15–20 minutes) 

 How to delete constraints and modify sketches. 

 Understanding the Degrees of Freedom:  

o Red lines = unconstrained 

o Green lines = fully constrained 

 Using the Solver Messages to identify and fix errors. 

Activity: 

 Have students create a sketch with intentional mistakes and use solver feedback to correct 

it. 
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5. Extruding Sketches to 3D (Optional, 15–20 minutes) 

 Switch to the Part Design Workbench. 

 Select the sketch and click "Pad" (extrude) to create a 3D shape. 

 Modify the extrusion height. 

Activity: 

 Students extrude their rectangle with a circle cutout into a 3D part. 

 

Homework Assignment: 

1. Written Task: Describe the difference between geometric and dimensional constraints. 

2. Practical Task: Create a fully constrained sketch of a T-shaped or L-shaped object. 

 

This lesson introduces precise sketching techniques, which are essential for parametric 3D 

modeling. Would you like additional exercises or a project at the end of this module? 
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Lesson 4: Parametric Design Basics 

Duration: 2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will understand the principles of parametric design in 

FreeCAD, how to use constraints efficiently, and how to modify designs dynamically by 

adjusting parameters. 

 

1. What is Parametric Design? (15–20 minutes) 

a. Definition and Importance 

 Parametric design means using defined parameters (dimensions, constraints) to control 

a model. 

 Unlike traditional CAD, parametric modeling allows for easy updates by changing 

variables rather than redrawing. 

 Used in engineering, architecture, and product design to create flexible models. 

b. Example of Parametric Design 

 A table where adjusting the leg height also adjusts the total table height. 

 A gear where increasing the number of teeth maintains proper spacing. 

Discussion Question: 

 Why is parametric design useful compared to manual adjustments? 

 

2. Understanding Constraints in Parametric Design (20–30 

minutes) 

a. Recap of Constraints from Lesson 3 

 Geometric Constraints: Keep the shape structured (parallel, perpendicular, tangent). 

 Dimensional Constraints: Define specific measurements (length, angle, radius). 

b. Modifying Constraints Dynamically 

 Open a previously created sketch (e.g., a rectangle with a hole). 

 Modify the length constraint and observe how the shape adjusts automatically. 
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Activity: 

 Have students constrain a rectangle and change its dimensions. 

 Observe how changing one value affects the whole design. 

 

3. Using Expressions & Parameters in FreeCAD (20–30 

minutes) 

a. Introduction to Expressions 

 FreeCAD allows users to use formulas and link dimensions. 

 Example: A rectangle’s height can be set as Width / 2. 

 This creates adaptive designs where one dimension controls another. 

b. Creating Custom Parameters 

1. Open the Spreadsheet Workbench. 

2. Create a new spreadsheet (Spreadsheet001). 

3. Define named variables (e.g., Length = 100mm, Width = 50mm). 

4. Link these variables to a sketch:  

o Select a dimension 

o Type Spreadsheet001.Length instead of a fixed number. 

Activity: 

 Have students create a rectangle where width is always half the height using 

expressions. 

 Modify the spreadsheet values and observe how the sketch updates. 

 

4. Practical Parametric Design Exercise (30–40 minutes) 

a. Design Task: Parametric Phone Stand 

 Students create a simple phone stand where:  

o The width adjusts based on phone size. 

o The angle of the support can be modified dynamically. 

b. Step-by-Step Instructions 

1. Create a new sketch for the base. 
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2. Add parametric constraints for width and height. 

3. Create a second sketch for the support. 

4. Link the angle using expressions. 

5. Extrude (Pad) the design and test modifications. 

Challenge: 

 Make a fully parametric stand where changing one number resizes the entire model. 

 

5. Reviewing & Testing Parametric Designs (15–20 minutes) 

 Modify parameters and see how the design updates. 

 Check for over-constrained sketches and fix errors. 

 Save, export, and prepare for 3D printing (if available). 

 

Homework Assignment: 

1. Written Task: Explain how parametric design improves efficiency in CAD. 

2. Practical Task:  
o Create a simple box with a lid where the lid automatically adjusts when the box 

size changes. 

 

This lesson ensures students understand and apply parametric design, setting a strong 

foundation for complex modeling. 

For Lesson 4: Parametric Design Basics, real-world projects that highlight the power of 

parametric design can help students understand how adjustable parameters lead to more efficient 

and adaptable designs. Here are some additional project examples that can demonstrate the 

practical use of parametric design: 

 

1. Adjustable Desk Stand 

 Description: 
Design an adjustable desk stand for a laptop or monitor. The stand should allow users to 

change the height, tilt, and angle of their device. 

 Key Parametric Elements:  
o Height of the stand (adjustable). 

o Tilt angle (adjustable). 
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o Width of the platform based on the size of the device. 

o Support structures that change in size based on the angle and height. 

 Why It's Useful: 
Students will learn how to create objects that are customizable and adaptable to different 

users or environments. They will define parameters for height, width, and angle and link 

them in the design to create a fully parametric model. 

 

2. Customizable Phone Case 

 Description: 
Design a customizable phone case that can fit multiple phone models by adjusting to 

different dimensions. Students would create a model where the case's size and shape 

change based on the input phone's dimensions. 

 Key Parametric Elements:  
o Length, width, and thickness of the phone. 

o Position and size of button cutouts and camera holes based on the phone model. 

 Why It's Useful: 
The project helps students learn to design objects that can be automatically adjusted for 

different inputs. This is a practical example of how parametric modeling helps create 

objects that can fit a variety of sizes or specifications without manually creating each 

version. 

 

3. Adjustable Pipe Clamp 

 Description: 
Design an adjustable pipe clamp that can fit different pipe sizes (for use in plumbing, 

construction, or machinery). The clamp should have adjustable features that allow it to 

accommodate various pipe diameters. 

 Key Parametric Elements:  
o Diameter of the pipe (which changes the clamp size). 

o Clamp width and tightening mechanism (which adjusts based on pipe diameter). 

o Material thickness for strength and durability. 

 Why It's Useful: 
This project illustrates how a parametric design can be used to create functional products 

that adapt to different dimensions. Students learn how to create parametric models for 

parts that need to fit a range of sizes. 
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4. Modular Furniture System 

 Description: 
Design a modular bookshelf or storage unit that can be customized to fit different room 

sizes or needs. The bookshelf should consist of several modular pieces that can be added 

or removed based on the user's preferences. 

 Key Parametric Elements:  
o Width, height, and depth of the shelves based on space available. 

o Number of compartments and how they adjust based on size. 

o Structural support that adjusts as modules are added or removed. 

 Why It's Useful: 
This project emphasizes the power of parametric design for creating flexible products that 

can be tailored to different needs. Students learn how to design modular systems that can 

be expanded or shrunk based on parameters like available space or user needs. 

 

5. Customizable Gear Mechanism 

 Description: 
Design a gear mechanism (such as a gearbox or transmission system) where the 

number of teeth, gear diameter, and spacing are all adjustable parameters. This could be 

for applications in mechanical engineering or robotics. 

 Key Parametric Elements:  
o Number of teeth on each gear (affecting the gear ratio). 

o Gear diameter and spacing. 

o Shaft length and mounting hole positions. 

 Why It's Useful: 
Students will learn how to use parameters to design functional mechanical systems. 

Parametric design in gears allows for efficient design changes without the need to 

redesign each part from scratch, which is critical in fields like robotics, automotive, and 

machinery design. 

 

6. Personalized Keychain Design 

 Description: 
Design a personalized keychain where students can input their own text, images, or 

logos, and the model will automatically adjust to accommodate these elements. 

 Key Parametric Elements:  
o Text or logo placement and size. 

o Keychain hole diameter and position. 

o Keychain shape and size adjustments based on user input. 

 Why It's Useful: 
This simple project introduces students to parametric design through personalization. 
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They will learn how to apply basic design principles while creating something 

customizable for different users or situations. 

 

7. Customizable Enclosure for Electronics 

 Description: 
Design an enclosure (box or case) for an electronic project, such as a microcontroller or 

sensor. The design should allow for different sizes of electronic components, access to 

ports, and space for wiring, which can be adjusted through parameters. 

 Key Parametric Elements:  
o Dimensions of the enclosure based on the size of the internal components. 

o Placement and size of cutouts for buttons, LEDs, and connectors. 

o Thickness of the walls depending on material strength. 

 Why It's Useful: 
This project gives students a practical understanding of how parametric design can be 

used in electronics design and manufacturing, where custom enclosures are often needed 

for different products. 

 

8. Adjustable Bicycle Frame 

 Description: 
Design a bicycle frame that can be adjusted to fit various user sizes. The frame’s 

geometry, including seat height, handlebar position, and wheelbase, should all be 

adjustable. 

 Key Parametric Elements:  
o Frame length and geometry based on user’s height. 

o Position of the seat and handlebars. 

o Wheelbase and frame angle. 

 Why It's Useful: 
This project demonstrates the power of parametric design for creating customizable and 

ergonomic products. It can be an excellent introduction to how adjustable features can 

improve user experience in complex designs like bikes. 

 

9. Adjustable Lamp Design 

 Description: 
Create a lamp with adjustable parts like the height, angle of the lamp head, and rotation. 

The lamp’s design should be parametric, allowing users to modify the size or 

functionality. 

 Key Parametric Elements:  
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o Adjustable height and arm length. 

o Lamp head tilt angle and rotation. 

o Base size or material to support adjustable components. 

 Why It's Useful: 
This project offers students the opportunity to combine functional design and aesthetics, 

while also exploring how parameters can affect both form and function in a product. 

 

10. Parametric Shoe Sole Design 

 Description: 
Design a shoe sole with parametric features such as varying tread patterns, thickness, and 

cushioning zones that adjust to the user's weight and walking style. 

 Key Parametric Elements:  
o Thickness of the sole based on shoe size. 

o Tread pattern density and layout for different terrains. 

o Cushioning zones that adjust based on comfort or material choices. 

 Why It's Useful: 
This project demonstrates the application of parametric design in footwear engineering, 

where every part of the sole can be customized based on functional and aesthetic needs. 

 

These projects highlight how parametric design can be used to create objects that are 

customizable, functional, and adaptable across a range of real-world applications. By working on 

these projects, students will learn the importance of parameterization in design and how it leads 

to more efficient, flexible, and scalable solutions. 
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Lesson 5: Extrusion & Revolution 

Duration: 2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will understand how to use extrusion (padding) and 

revolution (rotating a profile around an axis) to create 3D objects from 2D sketches in 

FreeCAD. 

 

1. Introduction to Extrusion and Revolution (15–20 minutes) 

a. What is Extrusion (Padding)? 

 Extrusion, also called Padding in FreeCAD, is the process of giving thickness (depth) 

to a 2D sketch by extending it along a straight axis. 

 Used for creating solid objects like blocks, cylinders, or mechanical parts. 

Example: 

 A rectangle extruded into a box. 

 A circle extruded into a cylinder. 

b. What is Revolution? 

 Revolution, also called Rotating, takes a 2D sketch and rotates it around an axis to 

create a symmetrical 3D shape. 

 Used for creating objects like bottles, wheels, and bowls. 

Example: 

 A rectangle rotated around an axis forms a cylinder. 

 A triangle rotated creates a cone. 

Discussion Question: 

 Can you think of real-world objects that are made using extrusion and revolution? 

 

2. Creating 3D Shapes with Extrusion (20–30 minutes) 

a. Steps for Extruding a Sketch in FreeCAD 
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1. Switch to the Part Design Workbench. 

2. Click "Create New Sketch" and select a plane (XY, XZ, or YZ). 

3. Draw a rectangle (or any shape). 

4. Fully constrain the sketch. 

5. Click "Close" to exit the sketch. 

6. Select the sketch and click "Pad" (Extrude). 

7. Set the extrusion depth (e.g., 20mm) and click OK. 

b. Activity: Creating a 3D Box 

 Students follow the steps to extrude a rectangle into a box. 

 Modify the extrusion depth and observe changes. 

 Try extruding a circle into a cylinder. 

c. Additional Padding Options 

 Two-directional extrusion: Expand in both directions from the sketch plane. 

 Symmetric padding: Ensures the extrusion extends equally in both directions. 

 

3. Creating 3D Shapes with Revolution (20–30 minutes) 

a. Steps for Creating a Revolved Shape in FreeCAD 

1. Switch to the Part Design Workbench. 

2. Create a new sketch on a plane (XY, XZ, YZ). 

3. Draw a profile shape (e.g., half of a bottle or a bowl). 

4. Fully constrain the sketch. 

5. Click "Close" to exit the sketch. 

6. Select the sketch and click "Revolve". 

7. Choose the revolution axis (e.g., Y-axis). 

8. Set the revolution angle (default is 360° for a full shape). 

9. Click OK to complete the revolution. 

b. Activity: Creating a Revolved Cup or Bowl 

 Students draw a half-profile of a cup and revolve it to create a hollow cup. 

 Modify the revolution angle (e.g., 180° for a half shape). 
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4. Combining Extrusion and Revolution (30–40 minutes) 

a. Project: Designing a Simple Mechanical Part 

 Create a base plate using extrusion. 

 Add a cylindrical post using revolution. 

 Modify dimensions dynamically. 

b. Challenge: Create a Parametric Lamp Base 

 The lamp base shape is extruded from a rectangle. 

 The lampshade is revolved from a half-ellipse profile. 

 

5. Reviewing and Exporting 3D Models (15–20 minutes) 

 Modify extrusions to change object height and thickness. 

 Modify revolutions to change object symmetry. 

 Export models as STL files for 3D printing. 

 

Homework Assignment: 

1. Written Task: Explain the difference between extrusion and revolution in your own 

words. 

2. Practical Task:  
o Create a bottle using revolution. 

o Create a tabletop using extrusion. 

 

This lesson gives students hands-on experience with two essential modeling techniques in 

FreeCAD. 
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Lesson 6: Adding Features (Fillets, Chamfers, Holes) 

Duration: 2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will understand how to modify and refine 3D models using 

fillets, chamfers, and holes in FreeCAD to enhance both aesthetics and functionality. 

 

1. Introduction to Feature-Based Design (15–20 minutes) 

a. What Are Features in CAD? 

 Features are modifications applied to a 3D model to refine shape, functionality, and 

assembly. 

 Common feature tools in FreeCAD:  

o Fillets: Round off edges to improve strength and appearance. 

o Chamfers: Create beveled edges to make assembly easier. 

o Holes: Used for screws, bolts, ventilation, or reducing weight. 

b. Why Are These Features Important? 

 Fillets reduce stress concentration and sharp edges. 

 Chamfers guide fasteners into place and remove sharp corners. 

 Holes are necessary for mechanical parts that require fasteners. 

Discussion Question: 

 Can you name objects in daily life that use fillets, chamfers, or holes? 

 

2. Applying Fillets in FreeCAD (20–30 minutes) 

a. What Is a Fillet? 

 A fillet rounds off an edge or corner of a 3D shape. 

 Helps in reducing stress points in mechanical parts. 

b. Steps to Apply a Fillet 

1. Open FreeCAD and switch to the Part Design Workbench. 

2. Select an existing 3D object (e.g., a box). 

3. Click on an edge or multiple edges. 
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4. Click "Fillet" in the toolbar. 

5. Enter a fillet radius (e.g., 5mm). 

6. Click OK to apply. 

c. Activity: Rounding a Box’s Edges 

 Students create a rectangular block and apply fillets to the top and bottom edges. 

 Experiment with different fillet radii and observe the effects. 

 

3. Applying Chamfers in FreeCAD (20–30 minutes) 

a. What Is a Chamfer? 

 A chamfer replaces a sharp edge with an angled cut. 

 Used to reduce sharp edges and make parts easier to assemble. 

b. Steps to Apply a Chamfer 

1. Create a 3D object (e.g., a cube or cylinder). 

2. Switch to the Part Design Workbench. 

3. Select an edge or multiple edges. 

4. Click "Chamfer" in the toolbar. 

5. Enter a chamfer distance (e.g., 3mm). 

6. Click OK to apply. 

c. Activity: Chamfering a Mechanical Plate 

 Students create a rectangular plate and apply chamfers to the edges. 

 Adjust chamfer size and observe changes. 

 

4. Creating Holes in FreeCAD (30–40 minutes) 

a. Types of Holes in CAD 

 Through-hole: Passes completely through an object. 

 Blind hole: Stops at a specified depth. 

 Counterbore / Countersink: Used for fasteners to fit flush. 

b. Steps to Create a Hole in FreeCAD 
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1. Create a solid object (e.g., a block). 

2. Switch to the Part Design Workbench. 

3. Click "Create New Sketch" and select a top face. 

4. Draw a circle where the hole will be located. 

5. Close the sketch and select it. 

6. Click "Pocket" to cut the hole:  

o Choose Through All for a full hole. 

o Choose Dimensioned Depth for a partial hole. 

7. Click OK to confirm. 

c. Activity: Adding Mounting Holes to a Bracket 

 Students create a support bracket and add four evenly spaced holes. 

 Modify hole size and position using constraints. 

 

5. Project: Designing a Parametric Phone Stand (30–40 

minutes) 

 Students design a phone stand with:  

o Filleted edges for aesthetics and comfort. 

o Chamfered edges for ease of 3D printing. 

o Custom holes for cable management. 

Challenge Task: 

 Use parametric constraints so that modifying the phone width updates the entire stand. 

 

6. Reviewing and Exporting Models (15–20 minutes) 

 Modify feature parameters dynamically. 

 Test hole placement for 3D printing compatibility. 

 Save and export the model as an STL file. 

 

Homework Assignment: 

1. Written Task: Explain the difference between fillets and chamfers. 

2. Practical Task:  
o Create a cube with filleted edges. 
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o Create a plate with four holes and chamfered corners. 

 

This lesson helps students refine their design skills and prepares them for real-world CAD 

applications. 

Industry-Related Case Study for Lesson 6: Adding Features (Fillets, Chamfers, 

Holes) 

Case Study: Automotive Industry – Designing a Car Frame Component 

Overview: In the automotive industry, components like car frames, brackets, and structural 

supports are designed with specific features such as fillets, chamfers, and holes to optimize 

strength, reduce stress concentration, improve assembly, and ensure safety. One such component 

is a bracket used to mount an engine to the vehicle’s frame. 

Objective: The purpose of this case study is to show how fillets, chamfers, and holes are 

applied in the real-world design of a car component, focusing on how these features contribute to 

the performance, safety, and manufacturability of the part. 

 

1. Introduction to the Component: Engine Mount Bracket 

The engine mount bracket is a critical component that connects the engine to the vehicle’s 

frame. It must be designed to withstand significant stress while being lightweight and durable. 

The bracket must also fit precisely with other components, requiring features like holes for bolts 

and fillets for stress distribution. 

Key Features Required: 

 Fillets: Rounded edges to reduce stress concentration and prevent cracks or breakage. 
 Chamfers: Angled edges to ensure ease of assembly and prevent sharp edges that could be 

dangerous or difficult to handle. 
 Holes: Precision-drilled holes for bolts and fasteners, ensuring a secure fit and correct alignment 

during assembly. 

 

2. Fillets and Stress Reduction 

Problem: 
In a high-stress component like the engine mount bracket, sharp corners can create areas where 

stress is concentrated, leading to fatigue and eventual failure. 
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Solution: 
Fillets are added to the corners of the bracket. The fillet serves to distribute the stress more 

evenly along the part, reducing the likelihood of cracks and improving the longevity of the 

component. 

 Manufacturing Benefit: Fillets make the part easier to manufacture by reducing sharp corners, 
which are harder to machine. 

 Design Benefit: By adding fillets, the component becomes more durable, which is crucial for 
safety in automotive applications. 

Example: 
In FreeCAD, a designer uses the Fillet tool to round the inner corners of the bracket, adjusting 

the radius to the required specifications for stress distribution. 

 

3. Chamfers for Assembly and Safety 

Problem: 
Sharp edges on metal components can be dangerous during manufacturing, transportation, or 

assembly. They can also cause interference with other parts during the assembly process. 

Solution: 
Chamfers are applied to the edges of the bracket to create angled edges that are safer to handle 

and make assembly easier by preventing sharp edges from catching on other components. 

 Manufacturing Benefit: Chamfered edges are easier to machine and handle, reducing the risk of 
injury or difficulty during the manufacturing process. 

 Assembly Benefit: Chamfered edges also allow for easier alignment during assembly, ensuring 
that parts fit together smoothly without resistance. 

Example: 
In FreeCAD, the designer adds a chamfer to the outer edges of the bracket, specifying the angle 

and size of the chamfer to fit the assembly requirements. 

 

4. Holes for Fasteners and Precision 

Problem: 
To attach the engine mount bracket to the vehicle frame, precision-drilled holes are necessary to 

ensure that bolts and fasteners fit properly. Poorly placed holes can lead to alignment issues and 

failure of the connection. 

Solution: 
Holes are placed in the bracket using precise measurements to accommodate bolts and screws. 



29 
 

The diameter and location of each hole must be carefully calculated to ensure a secure 

connection. 

 Manufacturing Benefit: Holes with precise placement make it easier to manufacture the bracket 
with the correct tolerances. 

 Safety Benefit: Proper hole placement ensures that the bracket is securely attached to the 
vehicle, reducing the risk of the engine becoming detached during operation. 

Example: 
In FreeCAD, the designer uses the Hole tool to place holes at specific points on the bracket, 

adjusting the diameter and depth based on the required bolt size and tolerance. 

 

5. The Impact of These Features on the Final Product 

In the automotive industry, the use of fillets, chamfers, and holes not only improves the 

functionality and strength of the component but also ensures that the part can be easily and safely 

manufactured and assembled. These features are crucial in meeting both engineering 

specifications and safety standards. 

 Fillets reduce stress concentration, improving the part’s durability and longevity. 
 Chamfers make the part safer to handle and easier to assemble, reducing the risk of accidents 

during production. 
 Holes are essential for fastening the part securely and ensuring a precise fit during assembly. 

By using these features effectively, engineers can design components that are both efficient to 

produce and safe to use, which is critical in industries like automotive manufacturing where 

performance and safety are top priorities. 

 

6. Conclusion and Learning Points for Students 

This case study highlights the importance of adding specific features like fillets, chamfers, and 

holes in industrial design, particularly in the automotive sector. Through this real-world 

example, students can see the practical benefits of these features in terms of strength, safety, 

manufacturability, and assembly. 

Key Takeaways: 

 Fillets reduce stress and improve part longevity. 
 Chamfers improve handling and ease of assembly. 
 Holes ensure precise alignment and secure fastening. 
 These features are critical in ensuring that a part functions safely, efficiently, and is easy to 

manufacture. 
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Activity for Students: 
Using a simple bracket or frame design in FreeCAD, students will add fillets, chamfers, and 

holes to their models, adjusting the dimensions based on the functionality of the part. They will 

then discuss how these features would impact the design’s strength, safety, and manufacturability 

in a real-world scenario. 

 

This industry-related case study will help students understand how adding features in CAD 

models isn't just about aesthetics or basic functionality; it’s about optimizing designs for real-

world applications, where safety, cost-efficiency, and manufacturability are essential. 
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Lesson 7: Combining Parts (Boolean Operations) 

Duration: 2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will understand Boolean operations in FreeCAD and how 

they are used to combine, subtract, or intersect 3D objects to create complex shapes. 

 

1. Introduction to Boolean Operations (15–20 minutes) 

a. What Are Boolean Operations? 

Boolean operations allow designers to create complex models by combining simple shapes. 

There are three primary Boolean operations in FreeCAD: 

1. Union (Additive Operation) – Merges two or more objects into one. 

2. Difference (Subtractive Operation) – Subtracts one object from another. 

3. Intersection (Common Operation) – Keeps only the overlapping region of two objects. 

b. Why Are Boolean Operations Important? 

 They simplify complex modeling by combining basic shapes. 

 Used in mechanical design, architecture, and 3D printing. 

 Allows designers to create hollow parts, cutouts, and composite shapes. 

Discussion Question: 

 Can you name real-world objects that are created by combining simple shapes? 

 

2. Understanding Boolean Operations in FreeCAD (20–30 

minutes) 

a. Accessing Boolean Tools 

1. Open FreeCAD and switch to the Part Workbench. 

2. Create two or more simple 3D shapes (cube, cylinder, sphere). 

3. Select the objects and apply Boolean operations from the toolbar. 

b. Performing a Union (Adding Parts Together) 

1. Create a cube and a cylinder. 
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2. Position the cylinder partially overlapping the cube. 

3. Select both objects. 

4. Click "Boolean Union" to merge them into one solid. 

5. Observe how the two objects become a single unit. 

Activity: Create a hammer head by merging a cylinder and a rectangular block. 

 

3. Performing a Difference (Subtraction) (20–30 minutes) 

a. Steps to Create a Cutout Using Difference 

1. Create a cube and a cylinder. 

2. Move the cylinder so it intersects with the cube. 

3. Select the cube first, then the cylinder. 

4. Click "Boolean Difference" to subtract the cylinder from the cube. 

5. Observe how the cube now has a cylindrical hole. 

Activity: Design a block with a circular cutout using subtraction. 

 

4. Performing an Intersection (Keeping Common Areas) (20–30 minutes) 

a. Steps to Perform an Intersection 

1. Create a cube and a sphere, overlapping them partially. 

2. Select both objects. 

3. Click "Boolean Intersection" to keep only the overlapping region. 

4. Observe the result—a new shape formed from the common volume. 

Activity: Experiment with different object combinations to see how intersection works. 

 

5. Project: Creating a Custom Mechanical Bracket (30–40 

minutes) 

 Use Boolean Union to combine a base plate and a cylindrical post. 

 Use Boolean Difference to cut out mounting holes. 

 Use Boolean Intersection to create a unique connector shape. 

Challenge: Modify the design using parametric constraints so the cutout size updates 

dynamically. 
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6. Reviewing and Exporting Models (15–20 minutes) 

 Modify Boolean operations and observe the changes. 

 Ensure the final model is manifold (ready for 3D printing). 

 Export as an STL file for 3D printing. 

 

Homework Assignment: 

1. Written Task: Explain the difference between Union, Difference, and Intersection. 

2. Practical Task:  
o Create a keychain with a text cutout using Boolean Difference. 

o Create a table leg with a rounded base using Boolean Union. 

 

This lesson introduces students to advanced modeling techniques that are essential for creating 

complex 3D designs. Would you like to add an additional real-world case study for reference? 
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Lesson 8: Multi-Part Assemblies 

Duration: 2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will understand how to create and manage multi-part 

assemblies in FreeCAD using the Assembly Workbench, including aligning, constraining, and 

positioning multiple components to build a functional model. 

 

1. Introduction to Multi-Part Assemblies (15–20 minutes) 

a. What Is an Assembly in CAD? 

 An assembly is a collection of multiple 3D parts arranged to function as a unit. 

 Assemblies allow designers to check fit, movement, and relationships between 

components before manufacturing. 

b. Why Are Assemblies Important? 

 Used in engineering, architecture, and product design. 

 Helps in detecting interference between parts. 

 Allows for parametric changes in one part to update across the assembly. 

Discussion Question: 

 Can you think of real-world objects made of multiple assembled parts? 

 

2. Understanding FreeCAD’s Assembly Workbenches (20–

30 minutes) 

a. Available Workbenches for Assemblies 

 A2plus Workbench – Most commonly used for general assemblies. 

 Assembly4 Workbench – Advanced parametric assemblies with constraints. 

 Part Design Workbench – Used for multi-body design without constraints. 

b. Setting Up an Assembly in FreeCAD 

1. Open FreeCAD and switch to the A2plus Workbench (or install it from the Addon 

Manager if needed). 

2. Create or import multiple 3D parts. 
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3. Insert components into the assembly document. 

4. Use constraints to properly align and position the parts. 

 

3. Importing and Positioning Parts in an Assembly (30–40 

minutes) 

a. Steps to Insert Parts into an Assembly 

1. Create or open multiple 3D components (e.g., base plate, bolts, brackets). 

2. Save each part separately as a FreeCAD file. 

3. In a new file, switch to the A2plus Workbench. 

4. Click "Add a Part" and select the saved components. 

5. Arrange the parts manually or use constraints to position them. 

b. Common Constraints for Assemblies 

 Plane Coincidence – Aligns two surfaces. 

 Axial Alignment – Ensures two cylindrical parts share the same axis. 

 Distance Constraint – Fixes a specific distance between two parts. 

 Angle Constraint – Defines a rotation angle between parts. 

Activity: 

 Import two parts (a base plate and a cylinder) and align them using constraints. 

 

4. Creating an Assembled Model (40–50 minutes) 

a. Example: Assembling a Simple Mechanical Joint 

1. Create three parts:  

o Base block (foundation). 

o Rotating arm (attached to base). 

o Pin or bolt (connecting the arm and base). 

2. Import them into the A2plus Workbench. 

3. Apply constraints to:  

o Align the pin with the arm hole. 

o Constrain the arm to rotate around the pin. 

b. Activity: Creating a Hinged Door Mechanism 
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 Students assemble a door with hinges using constraints to allow rotational movement. 

 

5. Simulating Motion in an Assembly (30–40 minutes) 

a. Understanding Motion Constraints 

 Some parts need to be fixed while others can move. 

 Use the revolute joint to simulate a rotating motion. 

b. Steps to Simulate Movement 

1. Apply coincidence constraints to connect parts. 

2. Allow one part to be free-moving along an axis. 

3. Use Assembly4 Workbench for advanced simulations. 

Activity: 

 Simulate the rotation of a wheel attached to an axle. 

 

6. Final Project: Assembling a Parametric Desk Lamp (40–

50 minutes) 

 Base: Fixed and supports the structure. 

 Arm: Connected with a hinge for movement. 

 Lampshade: Attached to the arm with an adjustable constraint. 

Challenge: 

 Modify the arm length and observe how the assembly updates dynamically. 

 

7. Reviewing and Exporting Assemblies (15–20 minutes) 

 Test assembly constraints for errors. 

 Save the complete assembly as a FreeCAD project. 

 Export as a STEP file for sharing or manufacturing. 
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Homework Assignment: 

1. Written Task: Explain the purpose of at least three assembly constraints. 

2. Practical Task:  
o Create a bolt and nut assembly using axial alignment. 

o Design a simple hinge mechanism using rotational constraints. 

 

This lesson helps students understand real-world assembly design and prepares them for 

engineering projects. 
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Lesson 9: Drafting & Technical Drawings 

Duration: 2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will learn how to create technical drawings from 3D models 

in FreeCAD, understand essential drafting techniques, and generate drawings suitable for 

engineering and manufacturing. 

 

1. Introduction to Drafting and Technical Drawings (15–20 

minutes) 

a. What Are Technical Drawings? 

 Technical drawings are detailed, standardized representations of 3D models in 2D for 

manufacturing, construction, and engineering. 

 They include dimensions, tolerances, and annotations to convey all necessary information 

for producing a physical object. 

b. Importance of Drafting 

 Drafting is crucial for clear communication between designers, engineers, and 

manufacturers. 

 Accurate dimensions and annotations ensure the part is made to specification. 

 Essential for 3D printing, machining, construction, and product design. 

Discussion Question: 

 What types of products in the real world rely on technical drawings for production? 

 

2. Exploring FreeCAD’s Drafting Tools (20–30 minutes) 

a. Introduction to the Draft Workbench 

1. Open FreeCAD and switch to the TechDraw Workbench (used for generating 2D 

technical drawings). 

2. The TechDraw Workbench is specifically designed to produce professional-looking 

technical drawings directly from 3D models. 

b. Key Elements of a Technical Drawing 
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 Title Block: Contains information like part name, scale, material, and the designer’s 

information. 

 Viewports: 2D views of the 3D model (e.g., top, side, front). 

 Dimensions: Show size and tolerances. 

 Annotations: Include notes like material specifications, assembly instructions, or 

warnings. 

 

3. Creating a Technical Drawing from a 3D Model (30–40 

minutes) 

a. Steps to Generate a Drawing 

1. Create or import a 3D model in FreeCAD (e.g., a simple mechanical part like a 

bracket). 

2. Switch to the TechDraw Workbench. 

3. Click on "Insert a new page" to create a new drawing sheet. 

4. Use the “Insert View” button to place front, top, or side views of your 3D model onto 

the page. 

5. Choose the scale for the drawing (e.g., 1:2, 1:5, etc.). 

6. Position the views and adjust their size. 

7. Add additional views like isometric or section views if necessary. 

Activity: 

 Students create a technical drawing for a simple cube by adding multiple views (top, 

front, side) and adjusting the scale. 

 

4. Adding Dimensions and Annotations (30–40 minutes) 

a. Dimensioning Techniques 

1. Use the “Dimension” tool to add measurements to views. 

2. Linear dimensions (length, width, height) are added between two points or edges. 

3. Radial dimensions are used for circles or arcs. 

4. Angular dimensions are used to measure angles between lines or faces. 

5. Datum dimensions help establish a reference point for all other measurements. 

b. Annotation Tools 

 Leader lines: Used to connect notes or labels to specific parts of the drawing. 



40 
 

 Text notes: Used to add descriptive text to the drawing (e.g., material type, surface 

finish). 

Activity: 

 Students add dimensions and annotations to their technical drawing of the cube. 

 

5. Working with Sections and Detail Views (20–30 minutes) 

a. Section Views 

 Section views are used to show internal features of a model by "cutting" through it along 

a plane. 

 Use the “Section View” tool to create a cross-section of your model and view internal 

details. 

b. Detail Views 

 A detail view zooms in on a small part of the drawing to show more detail. 

 Use the “Detail View” tool to highlight a specific area of the drawing for better 

understanding. 

Activity: 

 Students create section and detail views of their 3D model to better represent internal 

features and complex geometries. 

 

6. Finalizing and Exporting the Drawing (20–30 minutes) 

a. Finalizing the Drawing 

 Review the drawing for completeness, ensuring all views, dimensions, and annotations 

are correctly placed. 

 Ensure the drawing is clear and readable, following standard engineering conventions. 

b. Exporting the Drawing 

 Once finalized, export the technical drawing as a PDF or SVG file for printing or 

sharing. 

 STL files for 3D printing may also be exported from FreeCAD, but technical drawings 

need to be in 2D formats. 
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Activity: 

 Students export their final technical drawings as PDF files for review. 

 

7. Final Project: Creating a Complete Technical Drawing 

(40–50 minutes) 

 Students design a mechanical part (e.g., a bracket, wheel, or gear) and generate a 

complete technical drawing.  

o Create multiple views: front, side, top, and isometric. 

o Add dimensions and annotations. 

o Create section and detail views as needed to explain complex areas. 

o Export the drawing as a PDF for submission. 

 

8. Reviewing and Critiquing Drawings (15–20 minutes) 

 Review the technical drawings as a class, highlighting key aspects like:  

o Correct dimensioning 

o Clear view presentation 

o Proper use of annotations 
o Standardization (alignment, scale, title blocks). 

 

Homework Assignment: 

1. Written Task: Describe the process of creating a technical drawing in FreeCAD and the 

importance of accurate dimensioning. 

2. Practical Task:  
o Create a detailed technical drawing of a simple object, such as a cube with 

holes or a small mechanical part. Include views, dimensions, and annotations. 

 

This lesson helps students grasp the fundamentals of technical communication through 

drawings and prepares them for real-world design tasks that require precision and clarity.  
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Lesson 10: Exporting & File Formats 

Duration: 2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will understand how to export their FreeCAD models into 

different file formats for various purposes such as 3D printing, sharing, or use in other CAD 

software. They will also learn the differences between common file formats and when to use 

each one. 

 

1. Introduction to File Formats in CAD (15–20 minutes) 

a. Why Are File Formats Important? 

 Different file formats are used for different purposes, such as 3D printing, sharing 

models with other designers, or importing models into other engineering software. 

 Each format has its own advantages and limitations. For example, STL is commonly 

used for 3D printing but doesn't preserve color or material data, while STEP files 

preserve more detailed information and are used for professional CAD workflows. 

b. Overview of Common File Formats in FreeCAD 

1. STL (.stl) – Common for 3D printing. Stores 3D mesh data (triangles) but does not carry 

parametric or material information. 

2. STEP (.step, .stp) – A widely used format for exchanging 3D models between different 

CAD systems. Retains parametric data and supports assemblies. 

3. IGES (.igs, .iges) – Another format for sharing 3D models, used in many industries, 

though less popular than STEP for modern workflows. 

4. DXF (.dxf) – Used for 2D drawings and can be opened in many other CAD programs. 

Common in drafting and technical drawing workflows. 

5. OBJ (.obj) – Common for exporting 3D models with textures and material 

information. Used in industries like gaming and animation. 

6. FCStd (.FCStd) – FreeCAD's native format, storing all parametric and design data for 

editing and future work. 

Discussion Question: 

 Why do you think it's important to use the right file format for a particular purpose, such 

as 3D printing versus creating technical drawings? 

 

2. Exporting from FreeCAD (20–30 minutes) 
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a. Basic Export Process 

1. Open the model you wish to export (e.g., a 3D part or an assembly). 

2. Click File > Export to bring up the export dialog. 

3. Choose the desired file format from the dropdown menu. 

4. Select the location where the file will be saved and click Save. 

b. Exporting to Common Formats 

1. STL for 3D Printing: 
o Best for simple geometry and 3D printing workflows. 

o Click File > Export, then select STL (*.stl). 

o Set the mesh quality (fine, medium, coarse) depending on your needs. 

o After exporting, you can use the STL file in slicing software like Cura for 3D 

printing. 

2. STEP or IGES for Professional CAD Sharing: 
o Best for exchanging models between different CAD systems. 

o Choose STEP (*.step) or IGES (*.igs) when exporting. 

o These formats preserve parametric data, allowing the model to remain editable 

across different platforms. 

3. DXF for 2D Drafting: 
o Ideal for 2D drawing exports, especially for laser cutting or CNC machining. 

o Click File > Export, then choose DXF and select the 2D views you want to 

export. 

o DXF files can also be opened in drafting software like AutoCAD. 

4. OBJ for Textured 3D Models: 
o Best for exporting 3D models with textures (commonly used in 3D animations 

and gaming). 

o Use OBJ (*.obj) when the model requires additional material or surface 

information. 

Activity: 

 Students practice exporting their 3D model into STL for 3D printing, STEP for CAD 

sharing, and DXF for 2D drawings. 

 

3. Exporting Assemblies and Multi-Part Models (20–30 

minutes) 

a. Exporting Assemblies 

 Assemblies can be exported in STEP or IGES formats to preserve part relationships and 

parametric data. 
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 Exporting as STEP:  
1. Open the assembly in FreeCAD. 

2. Click File > Export. 

3. Select STEP format and click Save. 

4. The assembly will maintain its individual parts and relative positioning in the 

exported file. 

b. Multi-Part Models in STL 

 When exporting multi-part models, STL files may be generated for each individual part. 

Ensure you select the right settings to combine parts into one STL file if needed for 3D 

printing. 

 In FreeCAD, parts can be grouped together in the Part Design Workbench to create a 

single STL file for printing. 

Activity: 

 Students export a multi-part assembly as a STEP file for CAD sharing and as an STL 

file for 3D printing. 

 

4. File Management and Version Control (20–30 minutes) 

a. Managing Multiple Versions 

 As you work on your project, it's crucial to keep track of the different versions of your 

model. This can be done by using descriptive file names or storing versions in different 

folders. 

 FreeCAD's FCStd format allows you to maintain all design data, which is helpful for 

revision control. 

 Save different versions (e.g., v1, v2, final, etc.) to easily revert to a previous version if 

needed. 

b. Organizing Files for 3D Printing 

 When preparing a model for 3D printing, organize your files by creating folders for each 

model and its corresponding slicing profile. 

 Label STL files with the printer settings or material used (e.g., bracket_v1_pla.stl). 

 Store all associated files, such as textures and support files, in the same directory. 

Activity: 

 Students organize their 3D models, technical drawings, and STL files into folders and 

name them appropriately for a project. 
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5. Advanced Export Options (Optional) (30–40 minutes) 

a. Exporting to Rendering Formats (e.g., VRML, COLLADA) 

 For rendering and animations, VRML or COLLADA formats can be used to preserve 

color and texture information along with geometry. 

 These formats are commonly used in industries like gaming, virtual reality, or 

architecture. 

b. Importing Files into Other Software 

 Learn how to import your exported files into other software for different tasks. For 

instance, importing an STL file into a slicing software for 3D printing, or a STEP file 

into SolidWorks for further refinement. 

Activity: 

 Students export their model in VRML or COLLADA format and load it into a 

rendering software (e.g., Blender) to visualize it in a 3D environment. 

 

6. Final Project: Exporting and Sharing Designs (40–50 

minutes) 

 Students design a functional mechanical part (e.g., bracket, gear, or simple 

assembly).  

o Export the part in multiple formats: STL for printing, STEP for sharing with 

another CAD user, and DXF for drafting. 

o Organize the files in a folder and prepare them for submission or 3D printing. 

 

Homework Assignment: 

1. Written Task: Describe the differences between STL, STEP, and DXF file formats and 

when to use each. 

2. Practical Task:  
o Export a simple 3D model as an STL file for printing, a STEP file for CAD 

sharing, and a DXF file for 2D drafting. 

o Organize and name the files according to best practices. 
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This lesson ensures that students understand the importance of file formats and exporting 

processes, enabling them to work efficiently with their designs across different platforms and for 

various purposes. 
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Lesson 11: 3D Printing Basics 

Duration: 2 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will understand the fundamentals of 3D printing, including 

preparing models for 3D printing, common types of 3D printers, and how to troubleshoot 

common issues. They will also learn how to convert their FreeCAD models into printable files 

and use slicing software. 

 

1. Introduction to 3D Printing (15–20 minutes) 

a. What Is 3D Printing? 

 3D printing (also called additive manufacturing) is a process where material is 

deposited layer by layer to create a three-dimensional object based on a digital model. 

 This technology is used in engineering, product design, medical applications, 

architecture, and art. 

b. How Does 3D Printing Work? 

1. A 3D model is designed in a CAD software (like FreeCAD). 

2. The model is converted into a printable file format (e.g., STL or OBJ). 

3. The file is loaded into slicing software (e.g., Cura or PrusaSlicer) that prepares the 

model by slicing it into thin layers. 

4. The printer reads the sliced data and starts printing layer by layer. 

Discussion Question: 

 What industries do you think would benefit the most from using 3D printing, and why? 

 

2. Types of 3D Printers (20–30 minutes) 

a. Fused Deposition Modeling (FDM) 

 FDM printers are the most common type of 3D printers used in schools and home 

environments. 

 These printers extrude a thermoplastic filament (such as PLA, ABS, or PETG) through 

a heated nozzle, layering it on the build plate to form the object. 

 Pros: Low cost, wide material variety, and easy to use. 

 Cons: Lower resolution and slower printing speeds compared to other methods. 
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b. Stereolithography (SLA) 

 SLA printers use a liquid resin that is cured layer by layer by an ultraviolet (UV) light 

source. 

 Pros: Higher resolution and smooth surface finishes. 

 Cons: More expensive, requires post-processing (cleaning and curing), and limited 

material choices. 

c. Selective Laser Sintering (SLS) 

 SLS printers use a laser to fuse powdered material (usually nylon or metal) into solid 

parts. 

 Pros: Can print complex geometries and stronger materials. 

 Cons: Expensive and typically used for industrial applications. 

Activity: 

 Show students a real 3D printer (if available) or videos of different types of 3D printers 

in action (FDM, SLA, SLS). Discuss the pros and cons of each printer. 

 

3. Preparing Models for 3D Printing (30–40 minutes) 

a. Checking the Model for Printability 

1. Solidify the Model: Ensure the 3D model is a solid body and does not contain any holes 

or gaps. 

2. Orientation: Set the correct orientation for printing. Some parts may need to be rotated 

to avoid printing issues such as overhangs or weak layers. 

3. Support Structures: Complex parts may require supports to prevent sagging during 

printing. 

4. Overhangs and Bridges: Ensure that parts with overhangs are designed to minimize the 

need for supports, or adjust the printer settings to accommodate them. 

b. Exporting from FreeCAD for 3D Printing 

 Export the model from FreeCAD in STL format (the most common format for 3D 

printing). 

 Ensure the resolution of the exported file is fine enough to capture all the details of the 

model. 

 To export:  

1. In FreeCAD, go to File > Export. 

2. Select STL format. 

3. Save the file. 
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Activity: 

 Students create a simple 3D model (such as a cube with holes or gear) and export it as 

an STL file for printing. 

 

4. Slicing the Model (30–40 minutes) 

a. What Is Slicing Software? 

 Slicing software converts the 3D model into instructions (G-code) for the 3D printer by 

slicing it into layers. 

 It also allows the user to adjust parameters such as layer height, fill density, print 

speed, and support settings. 

 Common slicer programs include Cura, PrusaSlicer, and MatterControl. 

b. Importing the Model into Slicing Software 

1. Open the slicing software (e.g., Cura). 

2. Import the STL file into the slicer by selecting Add Model. 

3. Adjust the scale, rotation, and position of the model if needed. 

c. Key Settings in Slicing Software 

1. Layer Height: The thickness of each printed layer. Smaller layers result in higher 

resolution prints but take longer. 

2. Fill Density: Defines how solid the model is (higher percentages lead to stronger 

models). 

3. Print Speed: Controls how quickly the printer moves. Faster speeds can reduce quality 

but increase print speed. 

4. Support Structures: Automatically generated to support overhangs and complex shapes. 

5. Infill Patterns: The internal structure of the model (e.g., honeycomb, grid). 

Activity: 

 Students use Cura (or another slicer) to import their STL model, adjust print settings, 

and generate the G-code for 3D printing. 

 

5. Printing the Model (20–30 minutes) 

a. Preparing the Printer 
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1. Load the material (filament or resin) into the 3D printer. 

2. Preheat the printer’s bed and extruder to the appropriate temperatures for the chosen 

material (e.g., PLA: 190-220°C for the extruder, 60°C for the bed). 

3. Ensure the print bed is level to avoid printing issues like poor adhesion. 

b. Printing the Model 

 Once the model is sliced, the G-code file is transferred to the printer, either via SD card 

or USB. 

 Start the print and monitor the first few layers to ensure proper adhesion to the print bed. 

Activity: 

 If available, allow students to observe a print job, or demonstrate with a small test print. 

If printing in class isn't possible, discuss how the printing process works and simulate it 

on a 3D printer software. 

 

6. Post-Processing the Print (20–30 minutes) 

a. Removing the Model 

 After the print completes, carefully remove the printed object from the print bed using a 

spatula or scraper. 

 If the model is stuck, use a bit of isopropyl alcohol or water to loosen it. 

b. Cleaning the Model 

1. Support Removal: If supports were used, carefully remove them using pliers, tweezers, 

or cutters. 

2. Sanding and Smoothing: Use sandpaper to smooth out any rough areas. For SLA prints, 

you may need to cure the model with UV light. 

Activity: 

 Students practice removing supports and sanding their printed model (if feasible). 

 

7. Troubleshooting Common 3D Printing Issues (20–30 

minutes) 

a. Common Problems and Solutions 



51 
 

1. Warping: When corners of the print lift off the bed, often due to uneven cooling.  

o Solution: Use a heated bed, print with brims or rafts, or ensure the room is at a 

stable temperature. 

2. Layer Shifting: When layers misalign, typically due to an issue with the printer’s 

hardware or software.  

o Solution: Check for loose belts or incorrect print speed. 

3. Poor Adhesion: When the model doesn’t stick to the print bed.  

o Solution: Clean the print bed, adjust bed leveling, or use a better adhesion 

method (e.g., blue tape, glue stick). 

Activity: 

 Discuss potential troubleshooting solutions for common printing issues that students may 

encounter. 

 

8. Final Project: Design and Print a Simple Object (40–50 

minutes) 

 Students design a simple 3D object (e.g., a keychain, bracket, or phone stand), prepare 

it for printing by adjusting print settings, and generate the G-code. 

 If possible, allow students to observe or participate in the actual 3D printing process. 

 

Homework Assignment: 

1. Written Task: Research and write about two common types of 3D printers (e.g., FDM 

and SLA) and their differences. 

2. Practical Task:  
o Design a simple object in FreeCAD (e.g., a cube with holes) and prepare it for 

3D printing by exporting it to STL format and setting up a print in ** 
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Lesson 12: Reverse Engineering & Design Challenge 

Duration: 2–3 class periods (45–60 minutes each) 

Objective: 
By the end of this lesson, students will understand the process of reverse engineering, the 

importance of analyzing existing designs, and how to replicate or improve those designs using 

CAD software. They will also apply these skills in a design challenge where they will reverse 

engineer a simple object and improve it. 

 

1. Introduction to Reverse Engineering (20–30 minutes) 

a. What Is Reverse Engineering? 

 Reverse engineering involves analyzing an existing product or object to understand its 

design, structure, and functionality. 

 The goal is to recreate or improve upon that design, often for purposes such as 

manufacturing, innovation, or product improvement. 

 Reverse engineering is commonly used in industries like product design, software 

development, automotive, and electronics. 

Discussion Question: 

 Can you think of an example where reverse engineering has led to a better product or new 

invention? 

b. The Reverse Engineering Process 

1. Select an Object: Choose a simple, everyday object that will be easy to take apart (e.g., a 

small toy, tool, or household item). 

2. Disassemble the Object: Carefully take the object apart, noting how the parts fit together 

and their function. 

3. Measure the Components: Use tools like calipers, rulers, or micrometers to record the 

dimensions and key features of each part. 

4. Create a CAD Model: Using the measurements taken from the object, create a 3D 

model of the parts in a CAD program (such as FreeCAD). 

5. Analyze the Design: Look at how the parts are connected and how they function. 

Identify potential areas for improvement or redesign. 

Activity: 

 Discuss an example of a common product, such as a plastic bottle or bicycle gear, and 

describe how you could reverse engineer it (measuring dimensions, creating parts, etc.). 
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2. Tools and Techniques for Reverse Engineering (20–30 

minutes) 

a. Measuring and Observing the Object 

 When reverse engineering, accurate measurement is critical. Here are common tools you 

can use:  

1. Calipers – Measure the internal and external dimensions of parts with high 

precision. 

2. Micrometers – For measuring small dimensions with more accuracy than 

calipers. 

3. Rulers – To measure larger dimensions or to get a rough estimate. 

4. Protractors and Angles Gauges – To measure angles and slopes. 

b. Documenting the Object’s Features 

 Record key details about the object, such as:  

o Material (Plastic, Metal, Wood, etc.). 

o Shape and Size (Length, Width, Height). 

o Connection Types (Screws, clips, snaps). 

o Functional Parts (How do they work? Do they move or rotate?). 

Activity: 

 Students take apart a simple object (e.g., a pen or toy car) and document the key features 

such as material, dimensions, and connections. 

 

3. Recreating the Object in FreeCAD (30–40 minutes) 

a. Creating 3D Models Based on Measurements 

1. Start with Basic Shapes: Begin by modeling the basic components using sketches and 

extrusions (e.g., cylinders, boxes, and other standard shapes). 

2. Add Details: Use features like fillets, chamfers, and holes to match the details of the 

original object. 

3. Assemble Parts: If the object consists of multiple parts, create them individually and 

then assemble them into the full design. 

b. Using the Parametric Design Approach 
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 Since you are recreating an object, you can use parameters to keep dimensions easily 

adjustable. This makes it easier to adjust the design if you identify errors or wish to 

improve it. 

Activity: 

 Students recreate a simple part of the object they reverse engineered, such as a gear or 

housing, using extrusions, sketches, and basic features in FreeCAD. 

 

4. Improving the Design (30–40 minutes) 

a. Analyzing the Original Design 

 Once the object is recreated, examine it critically:  

o Does it have any weaknesses (e.g., fragile areas, inefficient shapes)? 

o Can it be made more efficient or cheaper to produce? 

o Is there any room for improvement in terms of aesthetics or usability? 

b. Making Design Improvements 

 Modify Dimensions: Adjust dimensions to improve strength or functionality. 

 Change Materials: Suggest a new material that could be more durable or cost-effective. 

 Add Features: Consider adding features like ergonomic handles, reinforced corners, 

or snap-fit connections. 

Activity: 

 Students make at least one improvement to the design they’ve recreated (e.g., increasing 

wall thickness for durability or adding a more efficient shape). 

 

5. Design Challenge: Reverse Engineering and Improving a 

Product (60–90 minutes) 

a. Project Brief 

 For this challenge, students will reverse engineer a simple product (e.g., plastic bottle, 

small tool, or bracket) and improve upon the design. 

 Steps:  

1. Disassemble the object and record measurements and features. 

2. Create a CAD model of the object using FreeCAD. 
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3. Identify potential improvements and modify the design accordingly. 

4. Document the design improvements and explain the reasoning behind them. 

b. Presenting the Design 

 Once students complete the reverse engineering and design improvements, they will 

present their work:  

o Show the original object and explain the reverse engineering process. 

o Present the CAD model and discuss how they improved the design. 

o Justify their improvements (e.g., how it saves material, reduces cost, or 

improves usability). 

Activity: 

 Students form small groups and work on reverse engineering and improving a common 

object. Afterward, each group presents their new design and explains why their 

improvements are valuable. 

 

6. Reflection and Discussion (20–30 minutes) 

a. The Importance of Reverse Engineering in Product Design 

 Reverse engineering helps improve existing designs and innovate by learning from 

existing solutions. 

 It’s also an essential step in creating products that are more efficient, cost-effective, and 

user-friendly. 

 Discuss how reverse engineering can be applied in various industries (e.g., engineering, 

product design, tech, medical devices). 

Discussion Question: 

 How can reverse engineering help us innovate and create better products in the future? 

 

7. Final Project Assignment (Optional) 

 Design Challenge: 
Students will select a more complex object (e.g., a mechanical toy or kitchen tool) to 

reverse engineer and improve. They will submit a detailed CAD model of the object, with 

annotations explaining their design decisions, improvements, and justification for the 

changes. 
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Homework Assignment: 

1. Research Task:  
o Students choose a product that underwent significant reverse engineering and 

improvement. Write a report explaining how reverse engineering played a role in 

its redesign (e.g., automotive parts, smartphones, etc.). 

2. Design Task:  
o Create a CAD model of a simple object (e.g., a keychain or phone stand), then 

identify areas for improvement and make at least one modification based on 

functional or aesthetic considerations. 

 

This lesson provides students with a hands-on approach to reverse engineering by dissecting 

and analyzing an existing object, then recreating and improving the design using CAD tools. The 

Design Challenge encourages critical thinking and creativity, helping students apply the 

principles of engineering design to real-world problems. 
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CAD & 3D 

Printing 

Workshop 

 

 
 

 
In this introductory workshop  you will learn the basics of CAD and create models that you can print on a 

3D-Printer. 
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Download Freecad: https://www.freecadweb.org/downloads.php 

Download Cura: https://ultimaker.com/software/ultimaker-cura  

Download Inkscape: https://inkscape.org/release/0.92.4/windows/64-bit/ 

visit http: //3d.Sahraid.com 
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Tutorial 1:   Make Name Plate 
 

Learning Objectives:   

Part, Part Design, Draft Workbench, Make nameplates engraved text, nameplates embossed 

text, plaques, stencils, Text on a surface: 

Steps: 
1 

2   Double click icon  to start FreeCAD. 

3 

4 From the menu bar click File->New 

5 From Workbench Drop down Select ‘Draft’.  

6 

7 

8 

9 

10  

from Text’ , click anywhere on 11Click ‘Shape 
Graph plane 

12 

13 

14Click Auto 

15 

16 
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1In the Combo View panel click Top (XY) 

2 

3 

4 

5From the menu bar click Shape from text 

6 

7 

8In the Combo View panel: 

9Enter 'Southern' in the String box 

10Enter 0.6” in the Size box  

11Enter C:/Windows/Fonts/arial.ttf in the Font file 
box 

12Click Reset to clear X, Y and Z coordinate boxes 

13Click 'OK' 

14 

15 

16 

17 

18 

19 

20Verify the string appears as 
shown  

21 

22 

23 

24 
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25 

26Click on the letter S to select it   

27 

28 

29 

30Click 'Move' icon  

31 

32 

33Click anywhere on the string and press left mouse button 

34 

35 

36Drag the string to the center of the screen and release the left mouse button.  

37 

38 

39 

40 

41 

42Click 'S Shape String'  to select entire string 

43 

44 

45 

46Click the double arrow 'Draft Modification Tool' to expand the tool set 

47 

48 
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49 

50Click 'Draft to 
Sketch' tool 

51 

52Verify a new entry 'Sketch' appears in the Combo View panel 

53 

54 

55 

56 

57 

58 

59Select 'Part' from Workbench drop down. 

60 

61 

62 

63 

64 

65 

66Click 'Sketch' in the Combo View panel 

67 

68 

69 

70 

71Click 'Extrude' icon  

72 

73 

74In the Extrude dialogue box of the Combo View panel enter 0.3” in the Length Along text box  
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75 

76 

77 

78Press 'OK' in the Combo View 
panel 

79 

80 

81 

82 

83A new entry 'Extrude' will appear in the Combo View panel, click 
'Extrude' to select the string 

84 

85 

86 

87 

88Click the icon 'Isometric' in the menu bar 

89 

90 

91 
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92 

93Observe a 3-Dimensional view of the string, you can also view different perspective of the 

string by keeping 'Alt' key pressed while moving the cursor around 

94 

95Select 'Part Design' from Workbench drop down. Select  

96 

97 

98 

99 

100 

101 

102 

103 

104 

105 
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106Click 'Create Body' in the Combo View panel 

107 

108 

109 

110 

111Click 'Create Sketch'  

112 

113 

114 

115 

116In the Combo View panel click 'XY plane (Base plane)' to select the 
plane. 

117 

118Press 'OK' in the Combo View panel  

119 

120 

121 

122 

123 

124Click 'Rectangle' tool from the menu bar 

125 

126Bring the cursor just above the letter 'S' of the string 'Southern' drag the mouse down and 
right until the white rectangle 
covers the entire string 

127 

128 

129 

130 
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131Press 'Close' in the Combo View panel, the screen will now have a green rectangle. 

132 

133 

134 

135 

136Click Pad icon from the menu bar  

137 

138 

139 

140In the length text box of Pad parameter Dialogue box enter 0.05” 

141 

142Click the icon 'Isometric' in the menu bar,   

143 

144 

145A supporting plate appears underneath the string 
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146Press 'OK' in the Combo View panel 

147 

148Select 'Part' from Workbench drop down. 

149 

150 

151 

152 

153 

154 

155 

156 

157 

158 

159Click 'Body' in the Combo View 
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panel 

160 

161Click Compound Tools from the menu bar  

162 

163Verify a new entry 'Compound' appears in the Combo View pane 

164 

165Click Extrude, Click Compound while simultaneously keeping the 'Ctrl' 

key pressed to select both 

166 

167Click Compound Tools from the menu bar  

168 

169 Anew entry 'Compound' appears in the Combo View panel 

170 

171Click File->Save and give a file name 
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172 

173Click File->Export, in the Export Dialogue box select .stl extension 

174 
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Tutorial 2:  Make simple ruler with protractor, 3D Compass 
 

Learning Objectives:  

Part, Part Design, Draft Workbench, Sketcher, Arrays, Macros, Circular Text,  

 

Step 1: Protractor base 

1. Start FreeCAD  

2. From Workbench Dropdown Select ‘Part Design’.  
3. From the top menu bar select Edit>Preference 
4. In the Preference window select General>Tab Units and set the Unit System to US customary 

(In/lb) and click Ok

 

5. Click File->New,  click ‘Create Body’ , click ‘Create Sketch’ , double click 

‘XY Plane (Base Plane) . 

 

 

6. From the Tool menu  and select , bring the cursor in the middle until it shows a cross hair, draw 

a rectangle in the middle, press esc  
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7. Select Constrain horizontal  and click top horizontal line  
and set the length to 7

 
8. Click OK 

9. If the model exceeds widow length the click Zoom to fit  

10. Click Constrain Vertical distance , click right vertical line and enter 1” as the vertical distance

 Click OK 
11. The sketch will turn green showing fully constraine.
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12. Click Close in the Combo View Task panel  

13. The Part Design menu selection will appear, click Pad  and in the Combo View Tasks 

panel set the length to 0.04”  
14. Hover the cursor on the top layer of the model (it will turn yellow) and click to select the top 

layer, it will turn from yellow to green. 

15. Click Create sketch.  

16. You are now in the Sketcher Workbench  

17. Click Centered Rectangle  and draw a small rectangle in the middle.  

18. Click to select the center point of the rectangle and click to select Y axis , click to 

select Constrain horizontal distance , enter length 3” in the Insert length dialog 

, click OK. 

19. Click to select right side of the rectangle, click Constrain Vertical distance , enter length .25” in 

the Insert length dialog, , click OK, Click to select lower side of the 
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rectangle, click to select Constrain Horizontal , distance, enter length .02” in the Insert 

length dialog, , click OK,  

20. Click Close in the Combo View Task pane  

21. Select Draft Workbench  , Click double array next to Move icon to expand 

the option, click Array and in the Combo View dialog enter 7 for the number of X 
elements and 1 for the number of Y elements, X Intervals 1”

 ,  

22. From Workbench Dropdown Select ‘Part Design’.  
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23. Click Combo View Model Tab  and select Array , click Create a 

Shape binder , in the Combo View dialog box make sure  Array is selected as Object  

, click OK, 

24. Click double arrow next to the Pad icon to expand the selection 

 and Pocket icon , and enter 0.01” for the length and select 

Reverse  . 
25. And click OK, 
26. Click on an empty space to deselect everything. 
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27. Click on the upper layer of the model  to select the upper layer as 

reference plane, click Create sketch ,  

28. Click Centered Rectangle  and draw a small rectangle in the middle.  

29. Click to select the center point of the rectangle and click to select Y axis , click to 

select Constrain horizontal distance , enter length 3” in the Insert length dialog 

, click OK. 

30. Click to select right side of the rectangle, click Constrain Vertical distance , enter length 0.2” in 

the Insert length dialog, , click OK, Click to select lower side of the rectangle, 

click to select Constrain Horizontal , distance, enter length .02” in the Insert length dialog, 

,  

31. click OK, Click Close in the Combo View Task pane  

32. Select Draft Workbench  , Click double array next to Move icon to expand 

the option, click Array and in the Combo View dialog enter 13 for the number of X 
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elements and 1 for the number of Y elements, X Intervals 0.5” and click OK

 ,  

33. From Workbench Dropdown Select ‘Part Design’.  

34. Click Combo View Model Tab  and select Array001 , click Create a 

Shape binder , in the Combo View dialog box make sure  Array001 is selected as Object  

, click OK, 
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35. Click double arrow next to the Pad icon to expand the selection 

 and Pocket icon , and enter 0.01” for the length and select 

Reverse  . 
36. And click OK, 
37. Click on an empty space to deselect everything. 

38. Click on the upper layer of the model  to select the upper layer 

as reference plane, click Create sketch ,  

39. Click Centered Rectangle  and draw a small rectangle in the middle.  
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40. Click to select the center point of the rectangle and click to select Y axis , click to 

select Constrain horizontal distance , enter length 3” in the Insert length dialog 

, click OK. 

41. Click to select right side of the rectangle, click Constrain Vertical distance , enter length 0.1” in 

the Insert length dialog, , click OK, Click to select lower side of the rectangle, 

click to select Constrain Horizontal , distance, enter length .02” in the Insert length dialog, 

,  

42. click OK, Click Close in the Combo View Task panel  

43. Select Draft Workbench  , Click double array next to Move icon to expand 

the option, click Array and in the Combo View dialog enter 61 for the number of X 
elements and 1 for the number of Y elements, set  X Intervals 0.1” and click OK ,  

44. From Workbench Dropdown Select ‘Part Design’.  

45. Click Combo View Model Tab  and select Array002, click Create a Shape binder 
, in the Combo View dialog box make sure  Array002 is selected as Object, click OK, 
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46. Click double arrow next to the Pad icon to expand the selection 

 and select Pocket icon , and enter 0.01” for the length and 

select Reverse  

47. Click to select the center point of the rectangle  , click to select the Y axis, click  

Constrain Horizontal distance and set the length 76.2mm, , Click to 

select the top left point of the rectangle, click to select the Y axis , click  

Constrain Horizontal distance and set the length 6 mm, ,  Click to select 
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the top left point of the rectangle, click to select the Y axis , click  Constrain 

Horizontal distance and set the length 6 mm, ,, 
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Step2: Protractor 

 

1. Start FreeCAD  

2. From Workbench Dropdown Select ‘Part Design’.  
3. From the top menu bar select Edit>Preference 
4. In the Preference window select General>Tab Units and set the Unit System to US customery 

(In/lb) and click Ok

 

 

Step3: Ruler Base 

 

5. Click File->New,  click ‘Create Body’ , click ‘Create Sketch’ , double click 

‘XY Plane (Base Plane) . 
6. Click  
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7. Select dropdown Create Rectangle from the Tool menu  and 

select Centered Rectangle , bring the cursor in the middle until it shows a cross hair, draw a 

rectangle in the middle, press esc  

8. Select Constrain horizontal  and click top horizontal line  
and set the length to 7”. 

9.  Click OK 

10. If the model exceeds widow length the click Zoom to fit  
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11. Click Constrain Vertical distance , click right vertical line and enter 1” as the vertical distance

 Click OK 
12. The sketch will turn green showing fully constrained. 

 

13. Click Close in the Combo View Task panel  
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Tutorial 3:  Make Fasteners, Helix, Path, Threads, Screws, Nuts and Bolts 
 

Workshop:   

Make screws, nuts and bolts and handles, In this tutorial you will design 1” bolt having 8 threads 

per inch (pitch = 1/8 or .125, from the specification the cutting trapezoid will have base1 = .125, 

and base2 = Pitch/4 = 0.03, the angle between two sides = 60o.  

 

Step1:  Nuts and Bolts 

 

1. From Workbench Dropdown Select ‘Part Design’.  
2. From the top menu bar select Edit>Preference 
3. In the Preference window select General>Tab Units and set the Unit System to US customery 

(In/lb) and click Ok

 

 

 

 

4. Click File->New,  click ‘Create Body’ , click ‘Create Sketch’ , double click 

‘YZ Plane (Base Plane) . 

5. Click the Circle tool , anchor the circle tool to the center , hover the cursor to 

the perimeter  and click to select the circle .  
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6. Click the Circle Diameter tool , and set the diameter to 1” . Click Close 

in the Combo View Task tab . 

7. Click Pad tool , and set the length to 2”.  

 

 

8. Select Create Polyline from the Tool menu and draw a trapezoid on upper left side of the 

plane,  

9. Select Constrain horizontal  and click top horizontal line  and set the length 
to 0.125”. 

10. Select Constrain horizontal  and click bottom horizontal line  and set the 
length to 0.027”. 

11. Select Constrain horizontal  and click bottom horizontal line  and set the 
length to 0.027”. 

12. Click left and right side to select both sides , and click Constrain equal  

13. Click left and right side to select both sides , and click Constrain equal , 



86 
 

14. Click left point of the Trapezoid , click X axis to select both, Click Constrain 

Vertical distance , and set the distance to 0.513 (slightly above the radius of the bolt). 

15. Click right point of the Trapezoid , click Y axis to select both, Click 

Constrain Vertical distance , and set the distance to 0.1 (slightly left to the bolt). 

16. Click Close in the Combo View Task tab, . 

17. Click double arrow >> next to the Pad icon to expand the selection , 

and select Subtractive Helix , in the Combo View Task tab set Axis to Horizontal sketch axis, 
set Pitch to 0.125 and set Height to 1.5”,  

 , click OK in Combo View Tasks tab, 
observe the threads appearing on the model. 

18. . 



87 
 

19. Click to select the flat end of the body and click Create sketch , 

click drop down Regular polygon and select Hexagon . 

20. Draw a hexagon center at origin, click two opposite points 

and click Constrain Horizontal distance set horizontal distance to 1.5”. 
21. Click Close in the Combo View Tasks tab. 

22. Click Pad and in the Combo View Task tab set length to 0.5”.  

23. Save the file  
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Tutorial 4: Make vase, stackable cups, text and design on curved surface 
 

Learning Objectives:  

 Curves Workbench, Loft, Path 

Step1: Text on Curved Surface 

 

1. Start FreeCAD  

2. From Workbench Dropdown Select ‘Part Design’.  

3. Click File->New,  click ‘Create Body’ , click ‘Create Sketch’ , double click 

‘XY Plane (Base Plane) . 

4. Click ‘Create Arc’ , Draw an arc; center on lower right coordinate and arc on upper right 

coordinate . Press ‘Esc’. 

5. Click ‘Constrain Radius’  , click arc , set the radius to 50 mm 

. Press Ok, press ‘Esc’ 

6. Click ‘Create Line’ ; Draw three connected line, two Vertical and one horizontal, 

connecting the two ends of the arc . Press ‘Esc’ 
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7. Click ‘Constrain Vertical’ and select the two vertical lines.  Press 
‘Esc’ 

8. Click ‘Constrain Horizontal’ and select the horizontal lines. 

 Press ‘Esc’ 

9. Click ‘Constrain equal’  and set the two vertical line equal.  
Press ‘Esc’ 

10. Click ‘Constraint Horizontal distance’ . Click left point of horizontal line 

, click origin , set horizontal distance to 50 mm 

. Press Ok, press ‘Esc’. 

11. Click ‘Constraint Point onto object’ . Click left point of horizontal line 

, click x axis’ . 

12. Click ‘Constrain Vertical distance’ , click ‘Vertical Line’ , and set the 

vertical line distance to 2 mm. . Press Ok. Press ‘Esc’ 
13. The sketch is fully constrain and will turn green 
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14. In the Combo View Panel Task tab click ‘Close’ . 

15. In the Cpmbo View Panel Model tab select ‘Sketch’ , click  
‘Revolution’  

16. In the Combo View Panel Task tab enter Angle 270 , click 

‘OK’  
17. Press ‘Alt’ and move finger on the touchpad to rotate the figure until the curved surface is 

visible . 

18. From Workbench Dropdown Select ‘Draft’ . 
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19. From the menu bar click ‘Auto’  click ‘Top XY’ . In the 

View panel click ‘TOP’  so the Grid plane top view is visible . If object is not 

visible click ‘Zoom to fit’ from the upper right hand cornot button.’  

20. From the Menu bar Click ‘Shape from the Text’ . 
21. In the ‘Combo View’ panel Task tab, enter string ‘LSU’, Height 20, Font File 

‘C:/Windows/Fonts/arial.ttf’ and ‘Reset Point’ so all ‘x, y, z’ are 0.00 mm and press ‘OK’.

. 

22. Verify ‘LSU’ appears on the graph . 

23. In the Combo View panel select  . 

24. On the menu bar if ‘Draft to Sketch’  tool is not visible, then click double arrow‘ 

so the tool is visible,  click ‘Draft to Sketch’  

25. Verify  appears in the ‘Combo View’ panel. 



92 
 

 

 

 

26. From Workbench Dropdown Select ‘Curves’.  
27. Press ‘Alt’ and move finger on the touchpad to rotate the figure until the curved surface is 

visible . 
28. Hover the cursor on the curved surface of the object, the surface will yellow 

 

29. Click on the curved surface and it will turn green   

30. Click on the ‘Sketch on Surface’ tool , 
31. Observe ‘Sketch on Surface’ option appears on the Combo View’ panel Model tab 

 
32. Expand the ‘Sketch on Surface’  by pressing the right arrow next to the ‘Sketch On Surface’ and 

observe Mapped Sketch selection.  
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33. Double click ‘Mapped Sketch’ and observe constrains appearing in the ‘Combo View’ panel Task 

tab.  

34. Click on ‘Constrain9’ , and in the dialogue box change the Insert 

Length to 120 , click OK 

35. Click on ‘Constrain10’ , and in the dialogue box change the 

Insert Length to 120 , click OK 

36. Press constrain11 and press ‘delete’ 

37. Press constrain12 and press ‘delete’ 
38. Now you should be able to move the blue construction rectangle in the design view. Hover the 

cursor over the lower left point of the rectangle, press the left mouse button and move the 
mouse till the blue construction rectangle covers ‘LSU’ in the middle.
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39. Click ‘Close’ on the Combo View panel Task tab  

40. Click ‘Sketch on Surface’ in the ‘Combo View’ panel Model tab to view 
property of the Sketch on Surface 

41. Click ‘Extra Object’ of the property , click 
the three dots on the right , the link page will pop up, click ‘Sketch001’ and click OK

 
42. In the property sheet settings, click ‘Fill Faces’ to see drop down option and select ‘true’, set  

Offset to -1, and Thickness to 2.00, and Reverse U to true  

43.  and click Refresh . 
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44. Observe embossed LSU in design view 

 

 

Step2: Make Vase 

1. Select Part Workbench in the Workbench drop down 

2. Select ‘Revolution’  in the Combo View panel Model tab (this is you would 

like to keep) press ‘Ctrl’ and select  simultaneously to highlight both, 

(this is you would like to remove from the body) and press Cut . 

3. Click Cut in the Combo View panel Model tab, click File, Click Export.  
4. Save the file as ‘LSU.stl’. 

5. In this tutorial you will make a Vase  using Loft tool 

6. From Workbench Dropdown Select ‘Part Design’.  
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7. Click File->New,  click ‘Create Body’ , click ‘Create Sketch’ , double click 

‘YZ Plane (Base Plane) . 

 

8. Step 2: Draw Circle 

9. Click the Circle tool , anchor the circle tool to the center , draw another circle 

and anchor to the center , 

 

10. Click the Circle Diameter tool , hover the cursor to the perimeter  of the 

first circle, and click to select the circle, set the diameter to 80 mm .  

11. Hover the cursor to the perimeter of the 2nd circle, and click to select the circle, 
and set the diameter to 78.5mm. 
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13. Step 3: Draw Circle 

14. Click the Circle tool , anchor the circle tool to the center , draw another circle 

and anchor to the center , 

 

15. Click the Circle Diameter tool , hover the cursor to the perimeter  of the 
first circle, and click to select the circle, set the diameter to 50 mm.  

16. Hover the cursor to the perimeter of the 2nd circle, and click to select the circle, 
and set the diameter to 48.5mm. 

17. Click Close in the Combo View Task tab . 

 

18. Step 3: Draw Hexagon 

19. Click ‘Create Sketch’ , double click ‘YZ Plane (Base Plane) . 
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20. Click the Hexagon tool , anchor the Hexagon tool to the center 

, Draw another hexagon anchor to the center 

. 

21. Click the Circle Diameter tool , hover the cursor to the perimeter of the first hexagon circle 

and click to select the circle and set the diameter to 110 mm

,  

22. click Constrain Point onto object , click to select the top point , click Y axis   
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23. Click the Circle Diameter tool , hover the cursor to the perimeter of the 2nd hexagon circle,

 and click to select the circle and set the diameter to 108.5 mm. 

 

24. Click Constrain Point onto object click to select the top point of the hexagon and click Y 

axis  to anchor the 2nd hexagon 

25. Step 4: Draw Circle 

26. Click the Circle tool , anchor the circle tool to the center , draw another circle 

and anchor to the center , 

 

27. Click the Circle Diameter tool , hover the cursor to the perimeter  of the 
first circle, and click to select the circle, set the diameter to 40 mm 

28. Hover the cursor to the perimeter of the 2nd circle, and click to select the circle, 
and set the diameter to 38.5mm. 
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30. Step 5: Draw Circle 

31. Click the Circle tool , anchor the circle tool to the center , draw another circle 

and anchor to the center , 

 

32. Click the Circle Diameter tool , hover the cursor to the perimeter  of the 
first circle, and click to select the circle, set the diameter to 60 mm.  

33. Hover the cursor to the perimeter of the 2nd circle, and click to select the circle, 
and set the diameter to 58.5mm. 

34. Click Close in the Combo View Task tab . 
35. Step 6: Raise platform 
36. In the Combo View Model tab click sketch001,  
37. In the Combo View Model tab, click Property Tab right arrow ‘>’ to expand the Attachment and 

set the z height to 30 mm  
38. In the Combo View Model tab click sketch002,   
39. In the Combo View Model tab, click Property Tab right arrow ‘>’ to expand the Attachment and 

set the z and set the height to 80 mm 
40. In the Combo View Model tab click sketch003,   
41. In the Combo View Model tab, click Property Tab right arrow ‘>’ to expand the Attachment and 

set the z and set the height to 110 mm 
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42. In the Combo View Model tab click sketch004,   
43. In the Combo View Model tab, click Property Tab right arrow ‘>’ to expand the Attachment and 

set the z and set the height to 150 mm 
44. In the Combo View Model tab click sketch005,   
45. In the Combo View Model tab, click Property Tab right arrow ‘>’ to expand the Attachment and 

set the z and set the height to 180 mm 

46. Click Close in the Combo View Task tab . 

 

47. Step 7: Loft 
48. In the Combo View Model tab click sketch1, while keeping the Ctrl button down click sketch001, 

while keeping the Ctrl button down click sketch002, while keeping the Ctrl button down click 
sketch003, while keeping the Ctrl button down click sketch004, while keeping the Ctrl button 
down click sketch005  

49. Click double arrow ‘>>’ next to the Pad icon  to expand the selection 

, click Additive loft , your model will show vase outline

, 
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50. Click anywhere of the screen and model will be displayed  , 
51. Save the file 
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Tutorial 5:  Make multi face dice, polygon mesh 
 

Learning Objectives:  

 Workbench Pyramids and Polyhedrons, Chamfer,  

 

Step1: Polygon Mesh 

 

1. From Workbench Dropdown Select ‘Pyramids and Polyhedrons’  

2. Click File > New, Click Icosahedron Truncated icon  to bring the 

model  

 

3. From Workbench Dropdown Select ‘Part Design’  

4. From Menu Bar Click ‘Edit’ , Click ‘Box Element Select’ , this 
will change the cursor in the main panel 

5. Bring the cursor near top left and drag to near bottom right so entire body is selected 

 

6. From menu Bar Click ‘Sub shape Binder’ ,  

7. Click ‘Binder’ icon in the Combo View Panel , 
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8. From Workbench Dropdown Select ‘Part’  

9. From menu bar click ‘Part’ , in the drop down click ‘Compound’, click ‘Explode Compound’ 

 
10. In the ‘Combo View’ panel expand the ‘Exploded Binder’ ,  
11. In the ‘Combo View’ panel, select all Binders from Binder.0 through Binder.31 while keeping the  

shift key down  

12. From the menu bar click ‘Extrude’  and select 10 mm length in Combo View  
13. Click on an empty space to make sure nothing is selected 

14. From menu bar click ‘Sphere’  
15. In the ‘Combo View’ panel click ‘Sphere’ and in the property view select Sphere 

and set Radius to 6 mm  
16. Step4: Boolean Cut 
17. In the ‘Combo View’ click first ‘Exclude’, press shift and click last ‘Exclude 031’ 

 

18. From menu bar click ‘Part’ , in the drop down click ‘Compound’, click ‘Make Compound’

 

19. Select ‘Sphere’ in the Combo View Panel, press shift and Select Compound 
, 

20. From menu bar click ‘Part’, in the drop down click ‘Boolean’, click ‘Cut
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21. From menu bar click ‘Sphere’ , select Sphere001 in the Combo View panel 

and change radius to 5.5  

22. Select ‘Sphere001’ in the Combo View Panel, press shift and Select Cut , 
23. From menu bar click ‘Part’, in the drop down click ‘Boolean’, click ‘Cut 

24. Your model will look as shown  
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Tutorial 6:  Make designer jewelry from image pattern 
 

Learning Objectives:  

Workbench Images, trace a photo, ‘.svg’ files   

 

Step 1 Create SVG file 

1. Download an image from Internet such as this flower  
2. Start Inkscape (please see Introduction for downloading Inkscape) 
3. Click File>Import and open the downloaded image, accept the default and click OK 

 
4. Click Path>Trace Bitmap and in the dialog select Edge detection and click OK 

5.  
6. When image is converted into vector graphics and appears in the dialog box 

, 
7. close the dialog, the converted svg image will also be placed on top of the download image, 
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8. Drag the image on one side and delete the original image  
9. Save the File as SVG file 
10. Step 2: Setup Workbench 

11. From Workbench Dropdown Select ‘Start’   

12. Create New Document  

13. From the Select dialog click SVG as geometry  

14. Image will appear in the window  

 

 

15. From Workbench Dropdown Select Part  
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16. Hover the cursor over image  and click on the highlighted image until 

it turns green  

17. Click Compound icon , 

18. In the Combo View Model tab select Compound , click Extrude  

19. In the Combo View Task tab select Custom Direction  and enter 
1.00 mm for length, click OK 

20. The extruded image is shown  

21. In the Combo View Model tab select Extrude  and press space bar to hide 

the image and show remaining path  

22. Click on different section of the image while keeping the Ctrl key down  

 

23. Click Compound icon , 
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24. In the Combo View Model tab select Compound 001 , click Extrude 

 

25. In the Combo View Task tab select Custom Direction  and enter 
4.00 mm for length, click OK 

26. The extruded image is shown  

 

27. In the Combo View Model tab select Extrude001 and press space bar to hide 

the image and show remaining path  

28. Click on different section of the image while keeping the Ctrl key down  

 

29. Click Compound icon , 

30. In the Combo View Model tab select Compound 002 , click Extrude  
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31. In the Combo View Task tab select Custom Direction  and enter 
8.00 mm for length, click OK 

32. The extruded image is shown  

 

33. In the Combo View Model tab, click Exclude, Exclude001, and Exclude002 and space bar to 

highlight all extrudes  

34. Click Part , Boolean and Union to combine all extrudes into a Union 

 

 

35. Save the file,  
36. In the Combo View Task tab, click to select Union 
37. Export the Union as .stl file 
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Tutorial 7:  Technical Drawing using TechDraw  
 

Learning Objectives:  

 Workbench TechDraw,; Learn Technical Drawing 

Step1: Make House Plan 

 

1. Start FreeCAD 

2. From Workbench Dropdown select ‘Part Design’  
3. Click File>New>Create Body> Create Sketch to start House base 
4. Double click XY Plane 

5. Create a sketch as shown in the figure  
6. In the Combo View Task tab click Close 

7. Click Pad   
8. Enter 40 as the extrude length and Close the dialog 
9. Select one side of the extrude and click Sketch 

10. Create a door using rectangle as shown  

11. Click Pocket   select length 2 mm 
12. Select one side of the extrude and click Sketch 

13. Create a window using rectangle as shown  

14. Click Pocket   select length 2 mm 
15. Select one side of the extrude and click Sketch 
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16. Create a window using rectangle as shown  

17. Click Pocket   select length 2 mm0 

 

18. Select one side of the extrude and click Sketch 

19. Create a window using rectangle as shown  

20. Click Pocket   select length 2 mm 

 

21. Select one side of the extrude and click Sketch 

22. Create a pattern for the roof as shown  

23. Click Pocket   select length 50 mm,  
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24. Select top left side and create a petter as shown  

25. Click Pad   
26. Enter 2mm as the extrude length and Close the dialog 

27. Select top left right and create a petter as shown   

28. Click Pad   
29. Enter 2mm as the extrude length and Close the dialog 

30. The resulting model is shown  
31. Select  Pocket004, Pad001, Pad002 while keeping the Ctrl key down 

32. From Workbench Dropdown select ‘Part’  

33. Click Part click Boolean  click Union  

 

34. Step 2: Technical Drawing 

35. From Workbench Dropdown select TechDraw  

36. From the menu bar click TechDraw> >  

37. You will be presented with the default template  
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38. In the Combo View Property Tab expand Template and double the three dots … 

 

39. Select ‘A4 Landscape blank’  as the default page,  the current page 
will be replaced by a blank page 

40. Click Refresh  

41. Ion the Combo View Model tab Page>Template will be added  
42. Also at the bottom of the page you will see two tab , original file and Page tab 

 

43. Click House  to view the model, In the Combo View Model Tab click Fusion

, click Isometric  View, 

44. Click TechDraw >Insert View , view will be added to the page, click 

  to bring the view into front , notice the label View and Vertex 
points on the View, 

45. In the Combo View Model tab View will also be added  
46. In the Combo View Model tab, click View and in the Property Page change label to Isometric. 

 

47. Click Refresh ,  
48. Press Ctrl ++ to enlarge the View 

49. To change the label Font size click Edit>Preference>TechDrasw and for the Label size 

enter 10  
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50. And to reduce the Vertex Point size click Scale tab , and enter 0 for Vertex Scale 

 

51. Click Apply, click OK and click refresh ,  

52. To add Front view of the House model click House , click to select Fusion in 

the Combo View Model tab, click Front icon , click TechDraw>Insert Image and click Page to 
view the Front View  

53. In the Combo View Model tab, click View001 and in the Property Page change label to Front 

View  

54. Click Refresh ,  
55. . 

56. To add Top view of the House model click House , click to select Fusion in the 

Combo View Model tab, click Top icon , click TechDraw>Insert Image and click Page to view 
the Top View  

57. In the Combo View Model tab, click View001 and in the Property Page change label to Top View

 

58. Click Refresh ,  

59. To add Right Side view of the House model click House , click to select Fusion 

in the Combo View Model tab, click Right icon , click TechDraw>Insert Image and click Page 
to view the Top View  

60. In the Combo View Model tab, click View001 and in the Property Page change label to Right Side 

View  
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61. Click Refresh ,  

 

62. To add dimensions such as height or length or width, click Page, click to select vertical line 

and click Insert Vertical dimension  and for width or length click to select horizontal 
line and click Insert Horizontal dimension 

 

63. . 
64. Similarly, to  add shading  
65. add Section View 
66. add Pad View 
67. Add notation 
68. Export to SVG or PDF 
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Tutorial 8:  Make protractor using circular text macro 
 

Learning Objectives:  

Part, Part Design, Draft Workbench, Sketcher, Arrays, Macros, Circular Text,  

Step 1: Protractor base 

 

1. Start FreeCAD  

2. From Workbench Dropdown Select ‘Part Design’.  
3. From the top menu bar select Edit>Preference 
4. In the Preference window select General>Tab Units and set the Unit System to US customery 

(In/lb) and click OK

 

 

 

5. Click File->New,  click ‘Create Body’ , click ‘Create Sketch’ , double click 

‘XY Plane (Base Plane) . 

6. Click Create arc icon , draw an arc anchor to center press Esc 

7. Click to select one end of the arc , click Y axis and click Constrain point onto 

object  to attach the point onto Y axis  
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8. Click to select the other end of the arc  , click X axis and click Constrain point 

onto object  to attach the point onto X axis  

9. The arc will aligned along X and Y axis  

10. Click arc , click , and enter 3” in the Insert radius dialog  

11. Click and draw lines from center to the two points of the arc, if you see redundant 

constrain message   , select and delete the Vertical and 

Horizontal constrains, the sketch will turn green when it is fully constrained.  

12. Click Close in the Combo View Tasks panel to close the 
Sketcher Workbench 

13. You are back to Part design Workbench 

 

14. Click Pad  , in the Combo View Model tab enter 0.2” for the length

 

15. Click Bottom icon , click to select bottom surface , click Create Sketch icon 
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16. Click Create arc icon , draw an arc anchor to the center , and draw a horizontal 

line and a vertical joining the two end points  

17. Select the center point and the point joining the line and click Constrain 

horizontal distance , enter .1” for length, click Constrain vertical distance, click Constrain 

vertical distance , enter .1” for length  
18. Click close in the Combo View Task tab, You are back to Part design Workbench 

19. Click Pocket  and enter .15 for depth 

20. Click Top icon to select top surface and click Create Sketch  

21. Select dropdown Create Rectangle icon  and draw a rectangle along the X axis , 
22. Press Esc 

23. Click to select the two right points and X axis , click Constrain symmetrical . 
24. Press Esc 

25. Click to select a left point and Y axis and press Constrain horizontal distance 

icon , enter 2.9” for length in the dialog box 

26. Click to select the vertical line of the rectangle  and press Constrain vertical distance icon

, enter 0.02” for length in the dialog box 
27. Click Close in the Combo View Task tab, You are back to Part design Workbench 
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28. Select Draft Workbench  , in the Combo View Model tab click to select 
Sketch002 

29. Click double array next to Move icon to expand the option, click Polar Array and in 
the Combo View dialog enter 91 for the number of elements,  

30. Click Reset point  and Close  ,  

31. From Workbench Dropdown Select ‘Part Design’.  

32. In the Combo View Model Panel select Array, click Create Shape Binder ,  

33. Click Pocket icon , and enter .02 for length 
34. Repeat step 1, except the distance between the rectangle and Y axis should be 2.8”, the length 

of the rectangle should be 0.02, name of the sketch is Sketch003, and polar array number of 
elements is 19. 

35. Repeat step 1, except the distance between the rectangle and Y axis should be 2.7”, the length 
of the rectangle should be 0.02, name of the sketch is Sketch003, and polar array number of 
elements is 10. 
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36. Click double arrow next to the Pad icon to expand the selection

  
 

37. Select Pocket icon , and enter 0.01” for the length and select Reverse

 . 
38. And click OK, 
39. Click on an empty space to deselect everything. 

40. Click on the upper layer of the model  to select the upper layer as 

reference plane, click Create sketch ,  
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41. Click Centered Rectangle  and draw a small rectangle in the middle.  

42. Click to select the center point of the rectangle and click to select Y axis , click to 

select Constrain horizontal distance , enter length 3” in the Insert length dialog 

, click OK. 

43. Click to select right side of the rectangle, click Constrain Vertical distance , enter length 0.2” in 

the Insert length dialog, , click OK,  

44. Click to select lower side of the rectangle, click to select Constrain Horizontal , distance, 

enter length .02” in the Insert length dialog, , click OK, Click Close in the 

Combo View Task panel  

45. Select Draft Workbench  , Click double array next to Move icon to expand 

the option, click Array and in the Combo View dialog enter 13 for the number of X 
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elements and 1 for the number of Y elements, X Intervals 0.5” and click OK

 ,  

46. From Workbench Dropdown Select ‘Part Design’.  

47. Click Combo View Model Tab  and select Array001 , click Create a 

Shape binder ,  
48. in the Combo View dialog box make sure  Array001 is selected as Object

, click OK, 
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49. Click double arrow next to the Pad icon to expand the selection 

 and Pocket icon , and enter 0.01” for the length and select 

Reverse  . 
50. And click OK, 
51. Click on an empty space to deselect everything. 

52. Click on the upper layer of the model  to select the upper layer 

as reference plane, click Create sketch ,  

53. Click Centered Rectangle  and draw a small rectangle in the middle.  
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54. Click to select the center point of the rectangle and click to select Y axis , click to 

select Constrain horizontal distance , enter length 3” in the Insert length dialog

, click OK. 

55. Click to select right side of the rectangle, click Constrain Vertical distance , enter length 0.1” in 

the Insert length dialog, , click OK, Click to select lower side of the rectangle, 

click to select Constrain Horizontal , distance, enter length .02” in the Insert length dialog,

, click OK,  

56. Click Close in the Combo View Task panel  

57. Select Draft Workbench  , Click double array next to Move icon to expand 

the option, click Array and in the Combo View dialog enter 61 for the number of X 
elements and 1 for the number of Y elements, set  X Intervals 0.1” and click OK ,  

58. From Workbench Dropdown Select ‘Part Design’.  

59. Click Combo View Model Tab  and select Array002, click Create a Shape binder 
, in the Combo View dialog box make sure  Array002 is selected as Object, click OK, 
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60. Click double arrow next to the Pad icon to expand the selection 

  

61. Select Pocket icon , and enter 0.01” for the length and select Reverse

 

 

62. Click to select the center point of the rectangle  , click to select the Y axis, click  

Constrain Horizontal distance and set the length 76.2mm, , Click to 
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select the top left point of the rectangle, click to select the Y axis , click  

Constrain Horizontal distance and set the length 6 mm, ,  Click to select 

the top left point of the rectangle, click to select the Y axis , click  Constrain 

Horizontal distance and set the length 76.2 mm,  

 

Step2: Make Protractor 

 

1. Start FreeCAD  

2. From Workbench Dropdown Select ‘Part Design’.  
3. From the top menu bar select Edit>Preference 
4. In the Preference window select General>Tab Units and set the Unit System to US customery 

(In/lb)  
5. click OK

 

6. Click File->New,  click ‘Create Body’ , click ‘Create Sketch’ , double click 

‘XY Plane (Base Plane)  
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7. Select dropdown Create Rectangle from the Tool menu  and 

select Centered Rectangle , bring the cursor in the middle until it shows a cross hair, draw a 

rectangle in the middle, press esc  

8. Select Constrain horizontal  and click top horizontal line  
and set the length to 7”. 

9.  Click OK 

10. If the model exceeds widow length the click Zoom to fit  
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11. Click Constrain Vertical distance , click right vertical line and enter 1” as the vertical distance 

 Click OK 
12. The sketch will turn green showing fully constrained.  

 

13. Click Close in the Combo View Task panel
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Tutorial 9:  Animation of Crank/Shaft assembly 
 

Learning Objectives:   

Introduction, FreeCAD basics, Navigation, Workbench, Macros, Sketch, Text on a surface: 

 

 

Step 1: Create Part Crank 
• Start FreeCAD  

• From Workbench Dropdown Select ‘Part Design’.  

• From the top menu bar select Edit>Preference 

• Click File->New,  click ‘Create Body’ , click ‘Create Sketch’ , double click 

‘XY Plane (Base Plane) . 

• Click ‘Create slot’ icon , anchor the point onto Y axis and drag to create slot  

• Click Constrain distance , select a side of the slot , and enter length 60 mm, 

• Click Constrain arc or circle , select arc of the slot , enter 6mm for the radius 

• Click ‘Create circle’,  
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•  click to select slot point , and draw circle ,  similarly, click to select the other 

point and draw circle around it  

• Click Constrain arc or circle ,click to select slot circle, enter 3mm for length 

• Click to select the other slot circle, enter 3mm for length 

• Press Close in the Combo View Task tab 

• Click Pad icon and enter 5 mm for length 

• From Workbench Dropdown Select ‘Assembly 4’  

• Click New Model , 

• Expand  ‘Unnamed’ in the Combo View Model tab and double click ‘Body’ to activate

 

• Click View>Draw Style>Wireframe > >  

• Click View > to remove Axis display 

• Right click Body and click Toggle active body  to make Body Active

 

 

 

• From Workbench Dropdown Select ‘Assembly 4’  
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• Expand ‘Create datum object’ and click ‘New Point’  

• Click OK in the dialog box to accept Point_1 as the object name 

• Place cursor on the lower circle and click to select it 

• In the Combo View Task tab Attachment Circle ‘Pad:Edge14’ will appear as the first entry 

 

• A point will also appear in the wireframe  

• Click Center of curvature as Attachment mode  

• Point_1 will also appear in the Combo View Model tab Body  

• Right click Body and click Toggle active body  to make Body Active

 

• From Workbench Dropdown Select ‘Assembly 4’  
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• Expand ‘Create datum object’ and click ‘New Point’  

• Click OK in the dialog box to accept Point_2 as the object name 

• Click Center of curvature as the Attachment mode  

 

• A point will also appear in the wireframe  

• Click OK in the Combo View Tasks tab and click Refresh icon , click anywhere in the 
window to deselect all objects 

• Point_2 will also appear in the Combo View Model tab Body  

• Double Click Body to activate it, click anywhere in the window to deselect everything 

 

• Expand ‘Create datum object’ and click ‘New Coordinate System’  

• Click OK in the dialog box to accept LCS_1 as the Local Coordinate System object name 

•  
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• In the Combo View Tasks tab Attachment window , enter 
Point_1 in the first text box, Point_2 in the second Textbox and click Inertial CS, click Align-O-X-Y 

 

• Axis points XYZ will appear around Point_1 and X axis will point towards Point_2 

 

• Click Refresh icon  

• Save the file as ‘Crank.FCStd’, Close ALL 

 

 

Step 2: Create Part Shaft 
• Start FreeCAD  
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• From Workbench Dropdown Select ‘Part Design’.  

• From the top menu bar select Edit>Preference 

• Click File->New,  click ‘Create Body’ , click ‘Create Sketch’ , double click 

‘XY Plane (Base Plane) . 

• Click ‘Create circle’ icon , anchor to the center, expand the radius to draw large circle, draw 
another small circle anchor to the center, draw another small circle inside the large circle but 

outside the small circle  

• Click ‘Constrain arc or circle’ icon , set large circle radius to 25mm, small concentric circle to 

5 mm, the peripheral circle to 3mm  

• Click ‘Toggle construction geometry’  

• Click Draw line icon  and draw a construction line joining center to the center point of the 

peripheral circle  



136 
 

• Click Constrain distance icon , click the construction line and enter 15 for the length

 

•  

• Click Constrain angle icon , click to select Y axis  and then click the construction line and set 

the angle to 30o  

• Click Close in the Combo View Tasks tab, 

• Click Pad icon, and set the length to 5 mm  

• From Workbench Dropdown Select ‘Assembly 4’  

• Click New Model , 

• Expand  ‘Unnamed’ in the Combo View Model tab and double click ‘Body’ to activate

 

• Click View>Draw Style>Wireframe > >  

• Click View > to remove Axis display 

• Right click Body and click Toggle active body  to make Body Active
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• From Workbench Dropdown Select ‘Assembly 4’  

• Expand ‘Create datum object’ and click ‘New Point’  

• Click OK in the dialog box to accept Point_1 as the object name 

• Place cursor on the upper circle and click to select it 

• In the Combo View Task tab Attachment Circle ‘Pad:Edge6’ will appear as the first entry 

 

• A point will also appear in the wireframe  

• Click Center of curvature as Attachment mode  

•  

• Point_1 will also appear in the Combo View Model tab Body  

• Right click Body and click Toggle active body  to make Body Active
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• Expand ‘Create datum object’ and click ‘New Point’  

• Click OK in the dialog box to accept Point_2 as the object name 

• Place cursor on the peripheral circle upper circle and click to select it 

•  

• Click Center of curvature as the Attachment mode  

 

• A point will also appear in the wireframe  

• Click OK in the Combo View Tasks tab and click Refresh icon , click anywhere in the 
window to deselect all objects 

• Point_2 will also appear in the Combo View Model tab Body  

• Double Click Body to activate it, click anywhere in the window to deselect everything 

 

• Expand ‘Create datum object’ and click ‘New Coordinate System’  
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• Click OK in the dialog box to accept LCS_1 as the Local Coordinate System object name 

•  

• In the Combo View Tasks tab Attachment window , enter 
Point_1 in the first text box, Point_2 in the second Textbox and click Inertial CS, click Align-O-X-Y 

 

• Axis points XYZ will appear around Point_1 and X axis will point towards Point_2 

 

• Click Refresh icon  

• Save the file as ‘Shaft.FCStd’, Close ALL 

 

Step 3: Create Master Sketch 
• Start FreeCAD  
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• From Workbench Dropdown Select ‘Assembly 4’  

• Click File>New 

• Click New Model icon  

• In the Combo View Model tab expand Model , click Origin and press 
‘space bar’ to select Origin, click ‘LCS_Origin’ and space bar to deselect it 

• The coordinate grid will appear in the main window 

 

• Click Refresh 

• Click ‘Create new sketch’ icon  

• Enter ‘Master Sketch’ as the sketch name, click OK 
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• Place cursor on the XY_Plane and click 
to select it 

• Click Plane Face in the Combo View Tasks Attachment  

• Click OK, click Refresh icon 

• Double click Master Sketch in the Combo View Model tab  

• Click Draw line icon , and draw two connected line starting from origin and ending on Y axis 
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• Click Constrain distance icon , click to select the first line   and set the 
length to 15 mm 

• Click Constrain distance icon , click to select the second line   and set the 
length to 60 mm 

• Click Constrain angle icon , click to select the first line, click to select Y axis and set the angle 

to 30o  

• Click Close in the Combo View Tasks tab 

• Click Variable icon , enter ‘Rotate’ for the name of variable  

• Double click Master Sketch in the Combo View Model tab,   

• Place cursor on the angle 30o  and double click to open Angle dialog 
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• In the Angle dialog box click ‘Enter an expression’ icon to open Formula editor

 

• In the Formula editor Textbox enter Varibles.Rotate , click OK to 
close Formula editor, click OK to close Angle dialog 

• Click Close in the Combo View Tasks tab 

• Click Animate assembly icon  

• Dropdown Variable to select ‘Rotate’, Range Begin 0, Range End 360, Check Loop, check Force-
render every step and click Run 

, 

• Notice first line rotate around center while one end of the large line follow the circle and the 
other end simply moves up and down. 

• Click Close Animate to stop animation 

• Click anywhere on the screen to deselect everything 
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• Click New Coordinate System  and accept LCS_1 as the name for new 
local coordinate system 

• Click to select Model in the Combo View Model tab, click origin and press space bar, click 
View>Toggle axis cross to remove cross from display, now the display should only show the lines

 

• Double Click Model to activate it, click anywhere in the window to deselect everything 

 

• Expand ‘Create datum object’ and click ‘New Coordinate System’  

• Click OK in the dialog box to accept LCS_1 as the Local Coordinate System object name 

•  

• Point the cursor at the start of the first line until the starting point turns yellow  

and click to select  the Vertex , 
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• Similarly, Point the cursor at the end point of the first line until the end point turns yellow

 and click to select  the Vertex2  

• Click Inertial CS, click Align-O-X-Y to move the red, 

green and blue axis lines align along the first line  

• Click Close, click Refresh 

• Click LCS_1  in the Combo View Model tab and press space bar to remove the 
axis points display 

• Double Click Model to activate it, click anywhere in the window to deselect everything 

 

• Expand ‘Create datum object’ and click ‘New Coordinate System’  

• Click OK in the dialog box to accept LCS_2 as the Local Coordinate System object name 

• Point the cursor at the start of the second line until the starting point of the second line 
turns yellow and click to select  the Vertex 2, 
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• Similarly, Point the cursor at the end point of the second line until the end point turns 
yellow and click to select  the Vertex3  

• Click Inertial CS, click Align-O-X-Y to move the red, green 

and blue axis lines align along the first line  

• Click Close, click Refresh 

• Click LCS_2  in the Combo View Model tab and press space bar to remove the axis 
points display 

• Double Click Model to activate it, click anywhere in the window to deselect everything 

 

• Expand ‘Create datum object’ and click ‘New Coordinate System’  

• Click OK in the dialog box to accept LCS_3 as the Local Coordinate System object name 
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• Point the cursor at the end of the second line until the end point of the second line turns 
yellow and click to select  the Vertex 3, 

• Similarly, Point the cursor at the starting point of the first line until the end point turns 
yellow and click to select  the Vertex1  

• Click Inertial CS, click Align-O-X-Y to move the red, green 

and blue axis lines align along the second line  

• Click Close, click Refresh 

• Click LCS_3  in the Combo View Model tab and press space bar to remove the axis 
points display 

• Click File->Save As, give the file a name 'CrankShaftMotion' 

Step 4: Final assembly 

• Click Insert Part icon  
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• Click Open File in the dialog box, select crank.FCStd file, the Model and Body appears in the 

dialog box  

• Select  crank#Body and click  

• In the Combo View Tasks tab click drop down Attach to: 

select Parent Assembly from the dropdown

 

• Select LCS_1 from the Body Panel, select LCS_2 from the Parent Assembly

 

• Click OK 

• The part will attach itself to the start point of sketch line 

• Click Insert Part icon  

• Click Open File in the dialog box, select Shaft.FCStd file, the Model and Body appears in the 

dialog box  

• Select  Shaft#Body and click  
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• In the Combo View Tasks tab click drop down Attach to: 

select Parent Assembly from the dropdown

 

• Select LCS_1 from the Body Panel, select LCS_1 from the Parent Assembly

 

• Click OK 

• The part will attach itself to the start point of first line  

• Click Animate assembly icon  

• In the Animate Assembly dialog click Run 
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• , 

• Notice assembly rotate around center  

 


